Debugging dead motherboard

I did the wrong thing… but can’t figure out what I broke.

Current state - when I plug in the power adapter, I get the two white LEDs, and the green LED on the compute module.
When I connect another computer or the factory keyboard to the LPC serial, I can interact with it. When (new) batteries are plugged in, it gives me healthy voltages for each. All LPC commands seem to work. When I enter “1P”, the white LEDs go out.
Nothing happens on the main LCD. Nothing happens on the CPU Serial 1 . I’ve tried booting from SD and EMMC, nothing either way.
I don’t see 5 volts on the USB bus. I don’t see any blown fuses, PTCs or resistors.

This problem started after I plugged in my new keyboard. I forgot to cut the 3v serial trace, so I must have backfed 3.3v into the LPC… but that’s the part that still works.

Any tips on where I should start debugging?

Hi, it sounds like you are using the wrong LPC firmware variant for your board perhaps? Do you have a beta board? There’s a rectangular badge on the board with some data including the version that ends with something like R01 / R02, or D-3 for a developer board. If you check board_reform2.c in the LPC firmware sources, you will see:

#define REFORM_MBREV_D2 2
#define REFORM_MBREV_D3 3
#define REFORM_MBREV_D4 4
#define REFORM_MBREV_R1 11
#define REFORM_MBREV_R2 12 // stock R2
#define REFORM_MBREV_R3 13 // R2 with "NTC instead of RNG/SS" fix

// don't forget to set this to the correct rev for your motherboard!

The board says mob20r02. I had flashed with Dev board firmware back when the batteries first died. I reflashed today with R2. Before the two white LEDS were on as soon as I plugged in wall power. Now the white LEDs for 5 & 3 don’t power on, but the 2 red LEDs do (despite not having batteries plugged in). The stock keyboard still works to go through the boot menu. When I power on, the two white LEDs flicker and go out. Serial console still doesn’t show any output.

Which position should the switch on the CPU module to be in to boot from SD card?

Two red LEDs turning on is fine/expected behavior. It means that charging is suspended.

If the white LEDs go out immediately, it probably means that LPC turns off the system immediately because it detected an undervoltage condition or similar. This should normally not happen with batteries disconnected.

To verify/workaround, you can comment out this line and rebuild and reflash the LPC firmware:

The boot switch has to be in the “ON” position to boot from SD card.

1 Like

The problem was that I was compiling from the out of date Github tree, not the one. When I installed up to date firmware, everything started working.

Thank you!


Ah, sorry for the confusion and glad you sorted it out. I have now deleted the GitHub repo.