LPC does not react anymore

I had some issues with the reform lately. After a couple of weeks of perfect suspend/resume cycles the LPC would not wake up the board. The LCD showed ‘Waking up LPC… 0%’ and went blank after some short time (~400ms).

So I shut down the board with Circle - 0 and restarted the reform. All was fine for a while. This time I shut down the reform with the shutdown command from linux.

After 2 days of no usage (the reform has been plugged into power) I opened the lid and saw this:

I had to unplug the batteries and replug them. I shut down the reform with the shutdown command again this time.

On the next morning I tried to start the keyboard by pressing the circle but the display would stay dark. This time I also had to reconnect the battery cables.

Then I came here to tell my story. Does that sound familiar?

Would there be output on any uart I could observe at this point?

What are my options to debug this?


This might be a dumb question but have you tried the LPC reset button on the motherboard?


no, I will do next time. But I wonder how it went into this state.

Keep in mind that shutdown from linux does not put LPC/KBD into powersave mode, so they remain in high duty cycle. At least for now, till proper LPC driver is built. So after halt you better do circle-0 to suspend LPC/KBD.
Also removing power is essentially the same as reset, so if you unplug batteries you don’t need to reset.


Ah, that has slipped my attention. Thanks for the hint!

one question that comes to mind: If I put the LPC into hybernation, it cannot charge the batteries right? So if I want to charge the laptop I should just shut down the i.mx and then hook it up to the power supply?

No it’s still checking batteries, just when som_off flag is set it can enter deep sleep and hence check less frequently. Which hints me that not only LPC and KBD are powered, but also all power rails. Eg the leds at the bottom are still lighted hence the power rails are active. So it’s like - SoM itself is entering power_down state but motherboard is still supplying full power.


This has happened again several times again the last week. The batteries have been charged on all occasions, pressing the reset switch did not work several times!

The only thing that helped was to unplug batteries from the main board.

Yes I always put the LPC into power off as suggested in this thread.

To clarify - you meant LPCRST button (on MBD) not the KBD RST (under the bezel)?
And it’s LPC which is not reacting (not waking up on OLED, even after LPCRST) not the KBD not reacting to the circle button?

it could be the keyboard not reacting to the circle button, too. I will try resetting the kbd next time and see if that helps.

Are you holding down the circle button for 1-2 seconds? On the new LPC and keyboard firmware, when the Reform is in deep sleep, you need to hold the circle button for 1-2 seconds to wake it up.

Yes, I do and I am aware of that change.