MNT Reform System Image V3 Beta

Yep, I have “Release System Image V3” in my TODO list for several weeks now, but I’m waiting for the issues to be resolved so we can have a working build again.

@mntmn triggered another run of the pipeline which should have produced a working image again. Check it out here: reform2-imx8mq · Artifacts · build (#783) · Jobs · Reform / reform-system-image · GitLab

3 Likes

This boots fine for me now thanks so much!

Much appreciated @josch :slightly_smiling_face:

Quick note: it appears that in the latest image, the brightness control keyboard shortcut in sway is broken. Seems like the slider works in gnome.

@bnys This must be an updated package, because mine stopped working after an apt upgrade. I have not done any troubleshooting, but brightnessctl still works so I guess the key assignment got borked somewhere.

Ah I see! I did run apt upgrade after getting the new image migrated to the NVMe drive.

I’m very impressed with gnome now! Slows down occasionally but otherwise animations work, settings app now seems to fully work (including networking), and overall it’s a fairly good experience.

1 Like

Okay, i don’t know what changed or when, but there is a Udev rule for brightnessctl; simply ensure your user is in the ‘video’ group and it’ll be back to normal on Sway.

2 Likes

@Sully_B Nice! Been wanting those shortcut keys back for ages. Looks like the same goes for audio output as well…

sudo usermod -a -G audio *username*
2 Likes

Awesome! Ran this for video and restarted…right as rain. Able to control brightness in sway yet again. Thanks!

1 Like

Hi, if there are issues with sysimage-v3, could somebody please either notify me here in the forum, or drop me a mail josch@debian.org or file an issue and @-mention me at source.mnt.re? It’s nice if problems get discovered but we should fix them at the source so that others can automatically benefit from the found solution without having to first search in the forum and then manually fix things.

I filed a MR with the fix here: fix ADD_EXTRA_GROUPS regex and set EXTRA_GROUPS to those used by d-i (!48) · Merge requests · Reform / reform-system-image · GitLab

1 Like

Hi @josch I do have an Issue with v3 with screen flickering in Xwayland.

I’m not sure if this is what was mentioned in the first post as “GPU glitches/freezes can occasionally happen (due to a mesa/new kernel issue)” tho.

You can reproduce with these steps:

  • Start reform-windowmanager
  • Start xterm
  • Type some text in then start moving the mouse around over the screen.
  • The new text will flicker like there are two video buffers and only one was updated.

This does not happen with v2.

Thanks for reading, let me know if there’s anything I can help with.

When trying to replicate your issue, I actually ran into another issue:

This looks like a mesa bug and I don’t know why the desktop doesn’t start at all and I only get graphics glitches. Once I killed it and tried running reform-windowmanager again I got to replicate your issue but I don’t think it’s a mesa issue because moving the mouse actually enters some text into the terminal. Can you confirm that observation?

Maybe start a new thread about this issue because I’m quite certain that this is not sysimage-v3 specific but if you had updated your kernel and mesa in v2 to their current versions you would run into the exact same issue.

1 Like

I confirm that I have the same issue with v2 and updated Mesa/Xwayland.

2 Likes

Finally got to install sysimage-v3 today, had to fiddle around with crypttab to get my LUKS+LVM on NVMe setup working but otherwise everything went smoothly.

Everything seems to be working fine, except for the HDMI output. My monitor that worked with v2 now doesn’t, even if I put imx8mq-mnt-reform2-hdmi.dtb into /etc/flash-kernel/dtbs/ (and update-initramfs)

Here’s the dmesg log when plugging the monitor in:

[ 3151.570988] cdns-hdmi-core: HDMI Cable Plug Out
[ 3151.839441] cdns-mhdp-hdmi: get block[0] edid failed: -22
[ 3151.845038] cdns-hdmi-core: Invalid edid
[ 3151.850015] imx-dcss 32e00000.display-controller: [drm] Cannot find any crtc or sizes
[ 3151.854440] cdns-mhdp-hdmi: get block[0] edid failed: -22
[ 3151.863419] cdns-hdmi-core: Invalid edid
[ 3151.873923] cdns-mhdp-hdmi: get block[0] edid failed: -22
[ 3151.879509] cdns-hdmi-core: Invalid edid
[ 3151.883663] imx-dcss 32e00000.display-controller: [drm] Cannot find any crtc or sizes
[ 3151.891663] cdns-hdmi-core: HDMI Cable Plug In

EDIT: weirdly enough, the first kernel messages at boot appear on the HDMI output and then it shuts off and the rest of the logs appear on the laptop display.

Yeah, manual twiddling is expected there. Since everybody’s setup is different I wonder if we can ever supply a script to do that conversion automatically without loosing any data.

That’s not how you switch to HDMI. You either use reform-display-config dual or you manually run:

$ "MNT Reform 2 HDMI" > /etc/flash-kernel/machine
$ update-initramfs -u

Though the plan of the person handling the upstream of our Linux kernel patches also plans to do away with having two different dtbs and wants to support dual display support with a single dtb in the future once they get around doing the necessary work.

Ooops, sorry about that, I forgot about this command ^^’

I gave it a bit more tries and it sometimes works, I don’t know what’s up with that. Looks like it has to be plugged in at boot, but sometimes I get no screen, sometimes I get HDMI.

Thanks a lot for all the work! :3

I’m seeing the following error with the latest apt upgrade…not sure if it’s just a me thing or not.

Setting up initramfs-tools (0.141) ...
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.141) ...
update-initramfs: Generating /boot/initrd.img-5.18.0-reform2-arm64
W: No zstd in /usr/bin:/sbin:/bin, using gzip
E: /usr/share/initramfs-tools/hooks/lvm2 failed with return 1.
update-initramfs: failed for /boot/initrd.img-5.18.0-reform2-arm64 
with 1.
dpkg: error processing package initramfs-tools (--configure):
 installed initramfs-tools package post-installation script subproc
ess returned error exit status 1
Errors were encountered while processing:
 initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)

It is not you. This is a problem of using Debian unstable: if you update at the wrong time, you get all the bugs. In this case, it’s this bug:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1014314

You can make upgrades a bit safer by installing the apt-listbugs package. With that package installed, you will get a prompt that shows you all release critical bugs in the package versions you are about to upgrade to and which will then allow you to abort the upgrade. That package is also part of the latest sysimage-v3 since this commit: mkuserland.sh: install apt-listbugs to prevent installing packages from unstable with RC bugs (3c702f0e) · Commits · Reform / reform-system-image · GitLab

4 Likes

Great, thanks for the clarification and apt-listbugs tip!