Reform-config sets only TZ

Calling from a terminal

sudo reform-config

only allows the TZ to be set, although the documentation states its also allows to set the keyboard.

Thank you for your issue report!

By “documentation” you probably mean the part in /etc/reform-help that says:

Set keyboard layout and timezone:

Or did you find the reform-config tool mentioned elsewhere?

@minute I do not see it mentioned in the handbook and now there is the reform-setup-wizard – maybe it is time to remove the reform-config script from reform-tools? It was only running these three lines:

sudo dpkg-reconfigure keyboard-configuration
sudo systemctl restart console-setup
sudo dpkg-reconfigure tzdata

Ohh,
Thanks - I mixed up the ‘reform-config’ tool with the setup wizard - Sorry for the confusion
:blush:

In which situation did you want to run the reform setup wizard manually?

to redo the keyboard config

Ok here is where I got the info from: if you do ‘reform-help’ then it tells you to use ‘sudo reform-config’ to config keyboard and TZ - but that only does TZ.

Re-running reform-setup-wizard will do much more than change your keyboard config.

@minute maybe the wizard should warn the user loudly if it is being executed a second time manually?

If you want to change your keyboard layout, run this command to change it for everything before sway/wayfire:

sudo dpkg-reconfigure keyboard-configuration

This is the same as you would do for any other Debian based system. For sway or wayland you would edit your ~/.config/sway/conf.d/input or your ~/.config/wayfire.ini, respectively. You ure probably most interested in the xkb_layout setting.

2 Likes