Reform does not boot anymore, some circle key combinations do not work

Hi everyone

II have a weird issue with my reform today. First OLED screen began to not display anything. When I plugged the power adapter, OLED screen said that batteries level was 0.

At this time Reform power on but nothing on the screen. I teared down back panel an reset everything. Batteries levels are now correct but nothing happen on screen when power on.

I tried another SD, flash lastest image, flash mine, boot from eMMC, without batteries, with an external monitor on HDMI but nothing on screen.

With the keyboard, Circle + ESC does nothing like Circle + f1/f2 for keyboard backlight.

The last time I booted (last week) all worked well. Does someone have an idea?


as discussed in IRC, my theory is this: Important: Do this safety modification

to confirm the theory it I will inspect your device and fix it and send it back.

Hi Lukas,

When I power on the devices with Circle+1, the imx card led light power on and white leds on the motherboard power on too.