Reform does not turn on after SoM change

I have attempted to upgrade my Reform with the new A311D SoM and it seems like I’ve damaged something in the process.

Whenever I plug in the power cable, the 3V3 and 5V leds turn on for a splitsecond and then turn off.

The red D8 on the motherboard is turning on as soon as i plug the cable, otherwise nothing happens. The circle key does not turn on the oled.

I’ve discharged myself before the repair and did not damage the motherboard or SoM afaik. The only thing that stands out to me is the MIPI DSI cable, which is bent and a bit deformed because of the components next to the heatsink.

Since discovering this, I removed the A311D SoM and put in the old module, but the behaviour is still the same.

Any advice on how to troubleshoot this would be appreciated.


I’m sorry to hear about your trouble with the system.

This is normal.

The MIPI-DSI cable getting a squeeze is also normal.

Does LED D9 come on after a while (directly next to D8)? It could be that the issue is with the keyboard–maybe you have one with the -RC variant of Atmega32U4 (for a while we could only buy that one back in the chip crisis). Could you check this? (The chip is on the back side of the keyboard). These tend to lose the firmware. We’re doing free replacements of this chip with the non -RC variant if this happens to people.

Thanks for getting back to me so quickly.

Yes, it does come on after about 3 seconds.

The name of the chip is MEGA32U4-AU.

Is there something else I could check to diagnose the possible cause of this?

So I took the motherboard out of the case and connected a cable to the microusb port and then powered it on.

It does not show up in lsusb, the output of dmesg looks like this:

[ 1290.128703] usb 7-2: new full-speed USB device number 10 using ohci-pci
[ 1290.269706] usb 7-2: device descriptor read/64, error -62
[ 1290.517711] usb 7-2: device descriptor read/64, error -62
[ 1290.760715] usb 7-2: new full-speed USB device number 11 using ohci-pci
[ 1290.901711] usb 7-2: device descriptor read/64, error -62
[ 1291.149716] usb 7-2: device descriptor read/64, error -62
[ 1291.256775] usb usb7-port2: attempt power cycle
[ 1291.676722] usb 7-2: new full-speed USB device number 12 using ohci-pci
[ 1292.088730] usb 7-2: device not accepting address 12, error -62
[ 1292.224729] usb 7-2: new full-speed USB device number 13 using ohci-pci
[ 1292.640739] usb 7-2: device not accepting address 13, error -62
[ 1292.640811] usb usb7-port2: unable to enumerate USB device

Error 62 translates to Timer Expired in /usr/include/asm-generic/errno.h, not sure what to make of it, but searching for the error messages suggests a hardware related problem.

If you want to flash the motherboard’s firmware, you have to set the LPCP switch to ON and press LPC reset switch once before connecting a USB cable.

It looks like this was me panicking, while removing the SoM I must have somehow gotten the OLED connector loose. After connecting it properly, the OLED worked and I was able to boot with the new SoM.

Sorry for taking your time on this, looking forward to trying the new module :slight_smile:

1 Like

Great to hear! I hope you’ll enjoy the new module.