Running xorg on reform

I’m having trouble with Wayland on my new Reform; Firefox and chromium just show as opaque boxes, and Emacs can’t render any fonts: https://icosahedron.website/system/media_attachments/files/106/466/133/254/845/709/original/db79b7dc7f8512fc.jpg

I’m pretty useless without my exwm window manager anyway so I need to get xorg running, but I can’t find any details about how this works other than a brief mention in a tweet here that it’s possible: https://twitter.com/mntmn/status/1363201995117592576

I gather you need something called XWayland but the official docs for XWayland are woefully inadequate. Running XWayland from gnome just says “Fatal server error: Server is already active for display 0”

Any ideas?

There is a script called

reform-windowmaker

You have to install your favorite WM or DE and change the according line in the script (best make a copy and rename that).
I have used this to run fluxbox and only changed the last line to get it working.
If you need more help I can post some photos of the process and give more detailed information

1 Like

Thanks! This is a promising start. I don’t know why that script wasn’t included in my Reform’s OS, but I was able to find it on gitlab and get it running on my machine to launch my WM.

It still has a lot of problems; all the text shown in bitmap fonts looks great but normal fonts all still display with boxes the same as in the Wayland screenshot above. And the colors are all wrong.

Finally, Firefox and Chromium both refuse to show anything but a blank white box upon launch, so whatever problem was causing that in Wayland seems to have followed me around.

1 Like

Welcome! The problem on your screenshot stems from a missing environment variable:

export ETNA_MESA_DEBUG=nir

This switches on the NIR shader compiler in mesa. This is in the default .bash_profile for new users in the default system image. If you use another shell, that might be the reason why it is not set.

Edit: Xwayland is automatically started by the default sway and gnome DEs that we ship. Firefox and chromium should work out of the box.

2 Likes

How did you create your user account on your Reform? It sounds like the default skeleton with the .bash_profile and helper scripts was not copied.

Ah, that explains it! I set up my user with the provided scripts, but then I cloned my dotfiles repo onto my machine so I could have all my personal customizations but it never occurred to me that this would overwrite critical settings; I figured those would be stored somewhere in /etc/profile.d or something instead. Thanks!

Alright! I recommend to take a look at the .bash_profile and copy over any required env variables.

Would you take a patch to move the required environment vars into /etc/profile so that personalized dotfiles don’t break the GPU settings?

Also, should the ability to run xorg window managers be documented somewhere, or is its omission from the handbook deliberate?

Yes and yes! reform-windowmaker isn’t in the handbook because it was a last minute addition. It is however mentioned in reform-help. It should be added to the next version of the handbook.

I created an account on the reform gitlab but it hasn’t been approved yet, so here’s the patch for the profile change: https://p.hagelb.org/0001-Move-certain-settings-to-system-wide-profile.patch

But if you prefer I can move the discussion to gitlab once my account is approved.

1 Like

I just approved your account!

1 Like

I was also having the opaque window problem after copying my own dot files over. Additionally some fonts, notably in the Super-D “run popup” of sway, were showing as opaque squares…

Took me a bit to find this post. Adding the above environment variable fixes the issue for me!

Thanks.