Video freezes with scrolling

I’m having an issue with the ZZ9000, I could never get it to work properly since I bought it (which was quite a while ago, I had to do the Power-Fix).

I tried FW 1.6 up to 1.9.1, with Z3 RAM and without (plugging in 16MB FAST RAM into the normal A4000 sockets).

I tried multiple riser boards and even three different A4000 mainboards (two with Buster 9, one with Buster 11).

The Amiga has a new power supply, all capacitors replaced, everything tested with DiagROM and it runs rock-solid with a PicassoIV card.

The issue I have is that the card freezes whenever there’s a lot of movement on the workbench. For example, if I just type a document in the shell, it freezes shortly after it starts scrolling.
Using the scrollbar to move through a file list in DeliPlayer or iGame also makes the video output freeze (unless I do it reeeally slowly).

Sometimes there’s a Guru meditation, sometimes it just freezes. As the disk drive keeps clicking and even reacts to inserting a disk… maybe it’s just the video output that freezes?

According to ZZTop the power is pretty solid. A memory tester does not find any issues.

As long as I don’t do any quick scrolling, the Amiga also won’t crash.
Also, when I run native Amiga resolutions (either on the workbench or playing games with WHDLoad), the Amiga also doesn’t crash.

I’ve tried AmigaOS 3.1.4 and 3.2.0 and have the latest Picasso96 version from Individual Computers installed.

I’m at my wits end. As this happens with all mainboards, it seems to be something wrong with my card.

Hopefully someone can help me debugging it. I’m located in Germany and are also willing to send the card to someone who has a working card for testing so we can find out whether it’s the card or something in my setup that’s broken.

Any ideas how to proceed here?
Thanks in advance :slight_smile:

  • Amiga model: A4000
  • 680x0 CPU: 040
  • RAM Configuration: 2MB Chip, 128MB via ZZ9000 (no other FAST RAM)
  • Kickstart, AmigaOS Versions:
  • ZZ9000 Firmware version: 1.9.1
  • ZZ9000 Driver version: 1.9.1
  • Other Zorro cards: None

It’s not a heating problem caused by not sufficient airflow?
What are the temps of your ARM-Processor? (since to my understanding this happends when GPU seems to be working harder,lot’s of movement)
I have never experienced overheating but i almost directly bought a small heatsink for a dollar that i added on my chipset to help with the cooling since i thought why not help it release the heat.
I also have A4000D with Cyberstorm 060, Cyberscsi so all in all it’s a lot of heat in that crowded little box.
Here is an example heatsink: High Profile Heatsink 14x14x11mm - Black

This might sound silly, but could you run the system from cold boot with the case off and let us know if it persists?

Also does RTG resolution make a difference? If you’re running at 1920x1080x16-bit, could you try 1280x720x8 and 800x600x8?

I’ll do that and will also make a video.
However, it does that regardless how long the Amiga has been running.
So far, there’s no difference whether it worked for 5 hours or 1 minute.
I tried different resolutions, and while on an older firmware (1.6) it was a bit more stable when lowering the bitrate, it doesn’t seem to make a difference with the current firmware.