AGA Games crash after installing zz9000 drivers

  • Amiga model:4000
  • 680x0 CPU:060 non fpu
  • RAM Configuration:16 / 256
  • Kickstart, AmigaOS Versions:3.2.1
  • ZZ9000 Firmware version:1.11
  • ZZ9000 Driver version:1.11
  • Monitor model:
  • Other Zorro cards:fast ata 4000

whdload aga games crashes after installing zz9000 drivers. I tried to install driver 1.10 but the same thing happened. Then I tried to also use the 1.10 firmware, but the computer just would not boot.

If I try pinball illusions I get to the first screen showing the title of the game, then a black screen, or a black screen with a stuttering noisy sound. With pinball fantasies it locks up in the first screen where I can select,I dont remember, the table or something, and I cant move the mouse. Exiting the game wont work, I need to restart.

This only happens to aga games and demos.

Hi @uncleawesome

I have similar configuration as you, minus the 060, and do not have any problems running AGA games. Maybe try floppy version (ADF if you have Gotek) and see if that works, just for testing purposes? When you installed 3.2.1, did you do a clean install or over older version of AOS? I had issues with the WHDL games in the past where games which would be perfectly working, stop executing at some point, with DOS error #205, IIRC and only after a clean install this was resolved. When you tried 1.10, did you downgrade the firmware to 1.10? I can’t test Pinball Illusions for you at the moment as my PSU is sent for a replacement.

1 Like

Hi and thank you for replying. I have now changed to the full 68060 with mmu and fpu. And now it works fine actually. I did a fresh install of 3.2 upgraded to 3.2.1. And I tried to downgrade the firmware as well but then I could not boot.

Anyway it’s working fine now :slightly_smiling_face:

1 Like

Thats interesting I had the same problem but with a full 060 I think maybe its time to reload and then try the new Firmware Again LOL thanks for the question and answer. will update my question and once reloaded will forward my findings too

I figured out it’s roadshow that was the problem. Here is a link for more information: WHDLoad Problem with Roadshow - English Amiga Board