AGA modes DblNTSC / DblPAL failing with black screen

Starting this thread as I’m having problems with non-15kHz Amiga AGA modes passing through the ZZ9000 to HDMI.

  • Amiga model: A4000T (cbm, ntsc)
  • 680x0 CPU: 060 on a3660 v1
  • RAM Configuration: 2mb chip, 16mb motherboard fast
  • Kickstart, AmigaOS Versions: 3.2.1/3.2.1
  • ZZ9000 Firmware version: 1.11
  • ZZ9000 Driver version: Tried w/ 1.11 and w/o any driver
  • Monitor model: Dell U2410 LCD, and two different era Samsung LCDs
  • Other Zorro cards: none

I understand that the video slot data is sampled and re-emitted via the HDMI port, but this appears to me to not be working for non-15kHz modes on my machine. Most problematic are screens that get Promoted by the OS to the AGA Dbl modes, like DblNTSC and DblPAL (I realize you can de-select the mode promotion and/or not use Dbl modes)


Black screen on monitor connected to ZZ9000.


Are DblNTSC/DblPAL/Productivity/Euro modes expected to be sampled and re-emitted on the HDMI port?

Things I’ve tried so far & notes:

  • Reinstall of OS. No change.
  • Try the “pass-through” without any driver for the OS at all. No change.
  • Attach serial to card, watched it successfully detect NTSC and PAL and interlace modes. It seemed to think DblPAL and DblNTSC modes were both just PAL, at least according to the debug messages. Although I did not see any debugging messages in the source code for ‘dbl’ or ‘double’ or ‘productivity’, so that may be expected.
  • With OS drivers installed, I noted that the screen also went black if I dragged the screen bar down (in non RTG modes)
  • Black screen did not cause any of the tested monitors to complain about incompatible scan rates. (the Samsung monitor will visibly complain about rates too low or too high and display the rate)
  • Checked 5V supply on my motherboard at farthest point from power entry. 5.08V, also low ripple (imo).
  • Verified I am getting a picture via the DB23 in these modes
  • PAL/NTSC motherboard jumper had no impact to this behavior
  • Tried HDMI → DVI cable vs HDMI → HDMI. No change.

To Do:

  • Verify with the forum here that these modes should appear on HDMI
  • Check frequency of dot clock from my machine. Do I see clock rate change on my video slot in these weird modes?
  • Try to fully understand the pass-through functionality and what is in firmware vs bitstream. It was not clear to me how the mode was detected with a quick review
  • Add some debugging as the result of the above (?)
  • Need to get the build env and perhaps Vivaldo up. Not looking forward to the latter. Is there a Vivaldo version that’s not $$$ which can build this? Lukas’s notes seem to imply that there’s a lot of very particular settings, especially for place/route/optimization to make the bitstream. Ugh.
  • Try a different kickstart

tl;dr: Getting a black screen when on non-15kHz non-RTG modes via HDMI. PAL/NTSC/interlaced or not working fine.

I see the same sort of behaviour here. I’ve never had a ZZ9000 version lower than 1.11 installed so I can’t comment on whether DblPAL/DblNTSC ever worked and I’ve not really had the time to dig into it, certainly not in this depth. :slight_smile:

For the record, I’m running:

A4000D (AU/PAL), Rev11 Buster, ATX PSU
CyberStorm Mk2 60060@50MHz
CyberSCSI Mk2 with only a sd2scsi v6
2Mb Chip, 128Mb on CS Mk2, 256Mb on ZZ9000
Kickstart 3.2 / AmigaOS 3.2.1
Dell U2412M monitor (or Acer V226HQL)
No other Zorro cards
ZZ9000 Firmware 1.11
ZZ9000 Driver 1.11