Amiga 2000: No boot with ZZ9000 and Xetec SCSI Card


I’m having an issue with the ZZ9000 which is not allowing the computer to boot when the ZZ9000 and a Xetec SCSI card are installed at the same time:

Typical configuration:

  • Amiga model: Amiga 2000
  • 680x0 CPU: 68030 (TF 536 accelerator)
  • RAM Configuration: 1MB Chip, 64MB Fast (TF536) + 8MB Fast (GottaGoFastRAM)
  • Kickstart, AmigaOS Versions: 3.2.2
  • ZZ9000 Firmware version: 1.13
  • ZZ9000 Driver version: N/A (I don’t get far enough for this to be relevant)
  • Monitor model: Nexdock (HDMI)
  • Other Zorro cards: Xetec FastCard (SCSI card)

Symptoms: Under KS 3.2.2, a yellow screen (which I understand indicates RAM issues). Under KS 1.3, a flashing gray screen. Removing either the ZZ9000 or the SCSI card solves the issue.

I have tried multiple hardware/firmware changes in order to attempt to solve this or at least narrow-down the cause:

  • CPU: Removed 68030 (TF536) and replaced stock 68000. No change.
  • RAM: Removed GottaGoFast RAM. No change. (Also, as above, removing the TF536 represents removing 64MB of the RAM. Also no change.)
  • Kickstart: Tried both 3.2.2 and 1.3.
  • ZZ9000 firmware: Tried multiple versions. Tried 2MB. Tried 4MB. Tried “no autoboot”. Always Z2 firmware. No difference.
  • Other Zorro cards: Have tried multiple configurations of which slot each card is in. Have tried swapping the order of the cards. Have tried disabling “autoboot” on the SCSI card. Have tried enabling and disabling 2MB of Z2 RAM on the SCSI card (typically disabled). None of these changes have an impact.
  • Other experiments: Have tried swapping between INT 2 and 6. Have tried no jumper at all for INT (just to see what would happen). Have run through RAM tests on all available banks and found no errors.

I believe at this point I’ve run out of ideas for what I can do with the hardware in order to get these two cards to run together. Can anyone think of anything else I can try? It seems though like a pretty fundamental fault if we can’t even get Kickstart to start all the way up with both cards inserted. Is there somewhere I might be able to get more diagnostic information? Would the JTAG tell me anything useful here (I would need to purchase an adapter to try this).

Thanks in advance,