'Cannot Attach to PHY' error with A311D

Hi everyone,

I have just installed my a311D today ant test it with latest MNT images downloaded on gitlab.

I have an errors showing on stderr of my current tty sessions:

meson8b-dwmac ff3f0000.ethernet end0:  Register MEM_TYPE_PAGE_POOL RxQ-0
meson8b-dwmac ff3f0000.ethernet end0: __stmmac_open: cannot attach to PHY (error: -19)

These two lines are repeated 8 times. Then nothing for a few minutes and repeated again.

Theses messages appear even no Ethernet cable plugged. And when I plug one, no connections occurs and no LED light. Even with the cable which work with my previous CPU module (the imx8 one)

Does someone have an idea of what I am doing wrong?

I also see this error and cannot connect over ethernet. No flashing lights on the port, either. Just one solid amber light, with the other dark.

1 Like


this seems to be a regression in reform-tools 1.35 that is fixed in 1.36 which was released today. I’m sorry for the inconvenience! The problem was the set -e in /usr/sbin/reform-hw-setup, which caused the script to break prematurely.


@ephase, @lykso can you make sure that the issue you saw is now fixed? reform-tools with the set -e bug was only available starting yesterday at around 16:00 UTC which is after your messages. Did you maybe accidentally download system images that were not built from the main branch?

1 Like

I downloaded the image that was linked in the handbook.

The recent reform-tools update seems to have fixed it. Thanks!

1 Like

Uh oh… do you mean the link Artifacts · build (#3599) · Jobs · Reform / reform-system-image · GitLab? That one links me to Artifacts · build (#3599) · Jobs · Reform / reform-system-image · GitLab and that is a build of the staging and not main. This is wrong. @minute can you fix the redirect so that it only always points to artifacts from the main branch?

Hello @minute, work for me thank you!

@ephase did you also use this link to download the images? https://mnt.re/system-image Let me quote the link with backticks this time so that the forum software doesn’t mangle it…

Yes I downloaded it yesterday and tried it this noon. I need to update reform-tools because version was 1.35 on this image.

Perfect, thank you!

@minute I was about to suggest that https://mnt.re/system-image could instead point to https://source.mnt.re/reform/reform-system-image/-/releases but it seems that the latest release for sysimage-v4 also just points to https://mnt.re/system-image which in turn redirects to https://source.mnt.re/reform/reform-system-image/-/jobs/3599/artifacts/browse which are the artifacts for the staging branch. Maybe the release page should instead hard-code the artifact URL for each release and then https://mnt.re/system-image can point to the release page or https://mnt.re/system-image should just point to the specific job artifacts of the latest release.