Changing the default X session

Hello, I recently received my Pocket Reform, and I’m having a lot of fun with it. However, when I initially ran the setup, I selected the Wayfire desktop, because I wasn’t sure I will be able to use Sway well. I have since then tried Sway and I like it more, but I can’t find where that setting is set. I searched through all the configuration files in the user’s home directory, and I went looking through all the Xsession files in the /etc, trying to figure out where they take their program name from, but I wasn’t successful.

If I try to re-run the setup as a user, switching the desktop type does nothing, at least without the other steps that all fail because of missing permissions.

If I try to re-run the setup as root, it says there is no auth method and fails to start.

Does anybody know where that setting is saved?

Hi,

the 2 default desktops on Pocket Reform are both Wayland (wlroots) based and don’t use the X server, Xsession etc. They do have support for running X apps, but that’s another topic.

The TUI login screen you see after booting or when logged out is tuigreet, which is in turn a module for the greetd greeter daemon. The greeter takes care of launching the desktop of your choice.

The MNT Reform Setup Wizard writes the default desktop choice to the file /etc/greetd/config.toml. Replace the /usr/bin/wayfire in line 9 with /usr/bin/sway to change the default to sway, and vice versa.

6 Likes

Thank you, that works perfectly.