Green Screen on Bootup

I have a A4000D with an 060 Cyberstorm MkII, 128meg ram installed. Running OS3.2.2.1 with the 3.2.2 ROM. I have Version 1.13 software and firmware installed.

I’ve had the ZZ9000 in the computer for a few years and I kept having a recurring problem of a green screen at boot up. I can warm reboot through it. Also I was getting a blank screen at boot up occasionally that required me to restart several times before I could get it to '“wake up”. I assumed it was from either the motherboard RAM or the RAM on the MKII. However, since I was troubleshooting anyway, I pulled the ZZ9000 and the green screen issue and blank screen issue at boot up went away. The computer boots correctly every time.

As an aside, the red color is missing on the native modes. Rather it flashes back and forth and sometimes it’s steady with red and sometimes not. Arrgh! The red screen issue is not the ZZ9000’s issue I don’t think because I am getting that only when using native modes or native modes coming right out of the video port. Related at all?

I’ve done the following in troubleshooting,

  1. Reseated the ZZ9000 and the daughterboard mounted on it.
  2. Moved the slot the ZZ is in. Tried all of the slots with no difference.
  3. Reformatted the SD card and reinstalled firmware v 1.13
  4. Tried v1.12, the version that doesn’t have zorro ram
  5. Green screen happens even before installing the driver software (tried both ways)
  6. Pulled my hair out and beat my dog

Okay, maybe not step 6. Still have the green screen at startup up. Because of the RED color issue, I’m wondering if it’s all a motherboard issue? Any suggestions on my next step? I have ordered another ZZ9000 (R613963925 so soon maybe??) for my 3000D but I really want to figure out this 4000D issue before I pull my trusty PicassoIV out of the 3000.

Okay. Switched motherboards and I get the correct color using native mode now. The ZZ9000 causes the board to hang up I don’t get to the load disk screen. I’m thinking it was dying and now it’s dead.

I have tried different slots with nothing but the board installed and the floppy drive. Also have a scan doubler in the external display port. That’s it. Installed it hangs, with it out I go straight to the start screen.

So can I send the board back to be fixed? Is that a thing?

Lol, I hear crickets! I ended up replacing the daughterboard and all is well again.