I'm not getting stable image

  • Amiga model: 2000 rev 6.x
  • 680x0 CPU: 68030 50MHz (TF536)
  • RAM Configuration: 2MB ChipRAM + 64MB 32bit FastRAM
  • Kickstart, AmigaOS Versions: KS 47.102, OS 3.2.1
  • ZZ9000 Firmware version: whatever it shipped with
  • ZZ9000 Driver version: I’ve not got that far yet
  • Monitor model: Dell 1905FP-B
  • Other Zorro cards: none

I’ve slotted the ZZ9000 into my A2000
I’ve plugged in the video slot adapter and connected the ribbon cable
Power-on, I get this:

I’ve removed the video slot adapter and plugged in the Denise adapter with Denise chip, then reconnected the ribbon cable.
Power-on, I get this:

I’ve noticed that the Denise adapter I’ve been sent:

Is not the same as the one shown on the webstore:

Seems like mine is missing the IC and some SMD components?

I’ve tried two different Denise chips.
I’ve tried PAL and NTSC oscillators.
I’ve tried three different LCD monitors.

The issues remain.

I suspect the video slot flashing image has to do with the Agnus Tick signal, I use that, as opposed to PSU tick.
I tried skipping past the tick issue with the Denise adapter, but you can see that does not work ‘better’

I would like to:
a) verify the ZZ9000 sent to me is ‘good’
b) use my ZZ9000

How can I continue ?
Thank you,


if you want to use the Denise adapter, you have to use the A500 firmware, because that works with composite sync signal instead of H/V. Please give it a try.

The Denise adapter production version does not need the chips because all of the logic is handled in the FPGA.

Okay, the little quick start guide mentioned the Z2 or Z3 firmware but it didn’t clue me into there being an A500 firmware…nor did the A500 addendum sheet.

I found the firmware repository and then I was like 2MB or 4MB…looked at the SD card… 128MB… hum… but then just assumed it must be the memory size of the graphics card… Picked 4MB, downloaded, wrote to SD and booted up… black screen… damn…

So, I went back to my Indivision ECS and switched workbench to PAL High Res Interlaced, rebooted to verify it stuck, and then swapped out the Indivision ECS for ZZ9500CX and now I get this:

Okay… Now I can continue on…

I assume you know that NTSC High Res Laced is not working ?
Could be other modes as well… I’m just at the getting an image stage.

Moving along,

I bought P96 from iComp, installed that no trouble.
I then downloaded the ZZ9000 Drivers from here:

Made an ADF, and tried installing, but got this error:

It seems that if I say that I don’t have an A3000 / A4000 the installer errors and exits because it can’t find the ZZ9000.card.nodma file…
I’ve looked in the driver’s Libs directory, that file is not there…

So… I’m stopped again.

I tried the IRC channel.

Seems dead in there.

Thoughts on how to proceed ?

Hi again, glad you made some progress! NTSC modes should absolutely work. But we can look at that later.

The 2MB / 4MB distinction means the amount of Zorro 2 address space the ZZ9000 will occupy, as there is a maximum of 8MB available in Zorro 2 systems. If you have other cards or memory there, you might want to use the 2MB version, otherwise 4MB.

Please download the correct driver package here:

Direct link:

Alternative download link file set working
I’ve got ZZ9000 video modes in ScreenMode Preferences

Now to go find something that makes use of these :slight_smile:

1 Like

For now, let’s call it a BackDrop upgrade card :slight_smile:

So… back to the NTSC issues…
I have an NTSC ACE2b Agnus, the system defaults to NTSC.
If I select NTSC lace, the screen just blinks on and off
I can get around that by choosing PAL video modes
However, if I run an app like Sysinfo, it switches to NTSC and my screen starts blinking again. There really are not ‘good’ ways to keep the Amiga out of NTSC screen modes at all times.

So… How to make the ZZ9000 not blink the screen when legacy NTSC screen modes are called ?

Let me show you what I’m saying:

I start on the stable 800x600x16 Workbench screen
I double click Sysinfo
The screen mode changes and NTSC HighRes Laced is selected by Sysinfo and the screen starts blinking.
I move the mouse and select ‘Quit’ and the screen mode changes back to 800x600x16 and everything is fine again.

  • Amiga model: 2000 rev 6.x + ACE2b Agnus, 28.63636MHz system
  • 680x0 CPU: 68030 50MHz (TF536)
  • RAM Configuration: 2MB ChipRAM + 64MB 32bit FastRAM
  • Kickstart, AmigaOS Versions: KS 47.102, OS 3.2.1
  • ZZ9000 Firmware version: 1.11 A500 4MB
  • ZZ9000 Driver version: 1.11
  • Monitor model: Dell 1905FP-B
  • Other Zorro cards: none

Updated some of those ^^^^ as they have changed along the way.
P96 software installed

RTG modes working
OCS\ECS NTSC modes cause the display to blink on an off

(bonus observation)
If you turn the display brightness up, you can see it is blinking during the black screen portion of Workbench bootup as well.

I think we’ve got the right firmware, the right driver, the right Picasso.
I’m ready to get started on the OCS\ECS NTSC modes working part.

Legacy NTSC modes not working, I just get a flashing screen.
Do I need to exchange my ZZ9000 for one that is known to work with NTSC, or is there further technical support ?

Moved this to a new thread