No serial output with A311D in Pocket Reform

Just like the title says. I need serial output to debug a boot issue with the nvme drive, but I can’t get it to work with the A311D module. Works fine with the standard iMX8, though.

I’ve checked S2 and S1, hooked up as indicated on the board and in the handbook (the handbook is wrong as far as I can tell; pin 1 is GND), and get nothing with a vanilla system image. I verified the serial adapters I’m using are working by hooking them up to one another, and verified the GND pins were indeed GND with a multimeter.

So I broke out my little oscilloscope, verified it was still working by probing one of the I2C lines (RP_SCL0, on the other side of the board) and checked all the lines on the serial connector. I could see the 3v3 pullup on the RX lines, but no signal on any of them. Is there somewhere else I can probe? Something I should turn on or off or try? I’m out of ideas.

Just a simple thing, though since you pulled out the scope I figure you’ve already tried it, have you tried swapping Tx and Rx? The labels used for them on a lot of embedded stuff and usb to ttl serial adapters aren’t always the most intuitive (sometimes tx-tx rather than crossing them over). Also if your adapter has a jumper you’ll want it set to 3.3v, though I believe most are automatic for that besides the voltage they put on the optional vcc pin.

Yeah, I tried swapping TX and RX too, and the adapter with a jumper was set to 3.3 volts; I tried two different adapters before pulling out the 'scope because it’s a pain (cheap and hard to use interface).

1 Like