Oops. Not able to access “NET”

I was messing around and ended up changing some system tray setting and now I’m not able to click on “NET” to access wifi settings in SWAY. Can’t remember exactly what I did or how to undo this. Anyone got an idea of what I did?

connman-gtk is the application that runs when you click NET. Is it possible the connman-gtk window appears in workspace 1 but you are currently viewing another workspace? This occasionally happens to me - for example, when i click NET while in workspace 2, the connman-gtk window will display in workspace 1. Hasn’t been cumbersome enough for me to dive into.

1 Like

Thanks for the reply. I don’t see it in other workspaces and it doesn’t seem to open anywhere when I navigate to it. Is conman a custom build for mnt or can I simply remove and install again?

A brute method would be resetting all of ~/.config and ~/.local to defaults. I guess this is only an acceptable solution if you don’t mind a bunch of other stuff being reverted. You could also compare those directories to their defaults with diff to see what’s changed. The original contents can be found in /etc/skel

1 Like

I also experience this problem :frowning:

In my case I was not changing tray settings, but rather editing network interfaces to disable wifi being enabled by boot. Unfortunately, I was not able to restore functionality but have not tried to debug in an exhuastive way, yet.

The menu (waybar) is configured with ~/.config/waybar/config and is controlled by the network widget. There should be a parameter called “on-click” which launches the script “reform-connman-gtk.sh” which in turn opens up connman for you.

Check that you haven’t done anything to the waybar config that’d stop that line from working, such as a missing , at the end of the line before it, or if you deleted it.

The other thing if you’ve messed with /usr/bin/reform-connman-gtk.sh you can test it by simply running reform-connman-gtk.sh at the command line, all the file does is pkill any existing connman-gtk instance then start a new one.

This is how mine is currently setp

    "network": {
        // "interface": "wlp2*", // (Optional) To force the use of this interface
        "format-wifi": "📶 {essid} {signalStrength}%",
        "format-ethernet": "🔗 {ifname}: {ipaddr}/{cidr}",
        "format-linked": "🔗 {ifname} NO IP",
        "format-disconnected": "NET ×", 
        //"format-alt": "NET {ifname}: {ipaddr}/{cidr}"
        "on-click": "reform-connman-gtk.sh"
    },  
1 Like

The config and bin files look fine. To be clear, I think this was some setting in the connman GUI. The bonehead over here(me) checked the wrong box. Or maybe it was something else I did.
This is the message I get when trying to run connman-gtk.

(connman-gtk:2628): Gtk-CRITICAL **: 20:37:43.621: gtk_widget_get_scale_factor: assertion 'GTK_IS_WIDGET (widget)' failed

I’m not getting any error messages like that while running connman so I’d look into that as a cause. Have you updated debian lately? Perhaps you managed to get a mismatch of versions installed? Run sudo apt update then sudo apt upgrade to get things up to date and see if that persists.

1 Like