Scandoubler not working?

Hi,

First of all many thanks for the ZZ9000 the RTG + Ethernet works flawlessly and am really happy with it in my Amiga 3000. Amazing piece of kit !!! :pray:

I would like to have some confirmation as to how and if the Scandoubler works in the Amiga 3000; do I need to enable it somehow ?

Because when I launch Sysinfo or a game using the ECS chipset I need to switch to the VGA out on my Amiga 3000; I thought the ZZ9000CX was relaying the amiga native video signal to the ZZ9000 and that I would have everything show up on the HDMI port of the ZZ9000.

FYI I put the ZZ9000CX in the topmost slot in the amiga 3000 on the left, and the ZZ9000 in the Zorro slot on the right; I used the ribbon cable to connect the two.

Any insight would be most appreciated !

All the best,

David

  • Amiga model: A3000D
  • 680x0 CPU: 68RC060 ( No FPU )
  • RAM Configuration: 2meg chip ram, 3 meg onboard fast, 256mb 32bit BigRamPlus, 256mb from zz9000
  • Kickstart, AmigaOS Versions: 3.1.4.1
  • ZZ9000 Firmware version: 1.8
  • ZZ9000 Driver version: 1.8
  • Monitor model: Dell U2410
  • Other Zorro cards: individual computers Buddha Flash + Individual computers BigRam Plus

Hi David,

thanks for your post! Yes, you should absolutely automatically get a picture from the native Amiga output through HDMI. For example, you should see the Early Startup menu scandoubled on HDMI. What do you get instead? A black picture? Does the monitor go out of sync?

Maybe your monitor doesn’t support the standard mode of the scandoubler. Did you select the 50Hz or 60Hz mode during installation?

Best
Lukas

Hi Lukas, thanks for your feedback !

I do get an out of sync from my monitor indeed !

I tried both the 50hz and 60hz mode, rebooting each time. I checked also in ENVARC: if the parameter was present or not.

Further fiddling with installs, I however discovered one time where it did work: in the Amiga Startup Menu, I first get a black screen, but when I press the spacebar, it toggles and I can see everything through HDMI neatly scandoubled !

When I click reboot or switch the chipset to NTSC or PAL however and try an ECS game it is out of sync again and I get a black screen.

Please also note that I live in Canada and it is 60hz here ( if it helps ).

Hope you can help,

David

I might have a solution. I changed jumper J200 on my motherboard (A3000) to set my system to PAL as default and the scandoubler worked.

However I think NTSC or PAL should be detected by the card itself and set there no ?

1 Like

Very interesting. It sounds to me like NTSC is not displayed, but PAL is? ZZ9000 absolutely supports NTSC and detects it, too. It sounds to me like the display mode that ZZ9000 uses for NTSC doesn’t work with your monitor in this case. So we might need to tweak the timing. Can you confirm this is the case? (NTSC modes don’t work for you?)

NTSC modes don’t work for me.

DblNTSC, NTSC modes => black screen / sync problem
DblPAL => black screen / sync problem
PAL => OK

Also I saw that when in scandoubler mode, the display is shifted one line up, so that the top line is at the bottom. Please see the video here http://starplace.org/row_problem_zz9000.mov for an example and also the screenshot below.

Thank you again for taking the time to resolve this and again an amazing peace of tech !!

1 Like

Here is the manual for my monitor, if it helps, I think there is a resolution and timing table on page 11: http://www.qed-productions.com/downloads/dell/dell-u2410_manual.pdf

1 Like

Any news on the line shift and NTSC not working ?

All the best,

Dave

Hi Dave, I plan to work on this next week anticipating a FW1.9 release to go with the Batch 6+7 shipment.

Oh cool! Can’t wait thanks!!!

Just wanted to chime in that I have the opposite issue with FW1.8; PAL output goes out of range on an HP monitor I was using (just displays a message to switch to a supported range), while NTSC output syncs just fine. I switched to an older NEC monitor for the time being which can handle the sync but it isn’t as bright (the cathode backlight isn’t what it used to be). The Amiga in question is a PAL Amiga 4000D. FW1.8 is still very much worth it for me since it works great with my Cyberstorm Mk1 and provides 256MB of additional RAM without needing a BigRAM+.

1 Like