SER1 and the LS1028A


I have a reform2 with the ls1028a CPU module, and want to ultimately install my favourite operating system on it and would thus need to know what happens when I try to boot. Since this particular CPU module does not get output on the screen until the kernel has started, my only recourse was connecting via serial to the debug port.

I did this using a prolific usb-to-serial adapter I had lying around and by making an adapter for the reforms three-pin motherboard connector. I’m pretty sure I’ve used this usb adapter successfully with 3-wire serial before.

When I tried using it all I get over the serial link is a few garbage, high-ascii, bytes. It does not seem like the wrong speed, since it’s just a few bytes.
The speed I set was 115200,N,1 as instructed here, although I did try with various speed and parity settings to no avail. I also tried swapping the RX and TX pins in case I didn’t get that right.

Bridging the TxD and RxD pins in the adapter makes characters echo back to the host computer, so I think I got the adapter cable right.

What am I missing?

Can you give us the exact adapter&specs? Is it TTL level 3.3V, i.e. not RS232?

It’s one of those Prolific PL2303 based ones that everybody has, with the model number UC-232A. I googled the model number and that indicated that it’s made by Aten and their FAQ says 5V only. I guess that answers the question.