Speakers too Quiet? Try This

By default, the speaker output of MNT Reform is a bit quiet, and changing the volume with PulseAudio won’t dramatically change it.

There’s one more knob you can turn up that is only accessible via ALSA. Open a Terminal and type alsamixer. Then press F6 and select the wm8960-audio card. Navigate with Cursor keys to the Playback slider and turn it up like so:

Edit: I wrote alsactl here first by mistake.


This worked great!! Thanks, Lukas!

Does anyone have a working EQ plug-in? The stock sound, especially with headphones, seems a little flat compared to my iPod with a Wolfson DAC and it might be nice to fine-tune it a bit.

I tried these instructions but was unable to get them to change the sound (or at least I can’t tell if the settings make a difference):


I’ve also noticed that the bass is a bit lacking in the headphone output. Looking at the schematic and the DAC datasheet I’m thinking this is due to the choice of the DC blocking capacitors (C147 and C127) as 47uF, the value directly affects the bass response. With 32ohm headphones 47uF gives 1/(2pi * 32ohm * 47uF) = 106Hz. The datasheet gives an example of 100uF which would give 50Hz response. My main headphones are 24ohm, so the 47uF caps cuts the bass off at 147Hz which honestly is too high.

I’m going to see about ordering some 100uf (66Hz) and 220uF (30Hz) caps to replace those to try and improve the bass response. Ideally bipolar caps of some kind. Though looking at the board I’m not seeing any larger caps in that area and C127 and 147 both seem to be tiny 0603 cermaics which isn’t ideal for upgrading. Or really for audio in general as ceramics can change their characteristics as the voltage changes. Seems like plenty of space in the area for some larger electrolytics instead.


Found some 100uF 16v audio electrolytics that I already had as a test and replaced the 47uF ceramics with them. The 0603 pads were a real pain to deal with. They’re too small for putting a surface mount cap on so I was limited to through hole carefully mounted.

The difference is night and day for the audio output on the headphone jack with much improved bass response and the audio as a whole sounds much more rounded out.

I’ve got some 220uF 6.3v caps coming from digikey which should do a slightly better job and should be a little smaller as well for a better fit. As it is there’s enough room for them, though I’d want to probably glue them down to the jack to prevent vibrations from straining the pads.


Why replace if paralel capacitor connection adds up the capacity? Or there’s no way to solder anything on top?

I was originally planning to though I damaged C127 while trying to parallel on top of it (end cap broke off), so just removed both. There is another reason you’d want to remove them though as high value MLCC ceramic caps have issues in audio circuits, they change capacitance depending on the voltage applied to them, they’re microphonic meaning vibrations will change the capacitance, and they’re just not the most temperature stable.

So replacing with a 100-330uF electrolytic (or better a bipolar electrolytic though they are quite big) will give better characteristics in addition to improved low end response.

Replaced the 100uF 16v caps with 330uF 6.3v audio grade caps. Not as dramatic of a change as going to the 100uF, but still a marked improvement, especially with the 16 ohm earbuds. I would recommend probably going with 220uF 6.3v as a sweet spot between cap size and bass response if you were to do this.


had my machine for a few days. yesterday, was able to get (very quiet) sound out of a youtube video in firefox. today, nothing. found the instructions above, but:

there is no wm8960-audio listed on my system, only (default). And Master is already cranked to 100. Investigating, i noticed:

sl@reform:~$ dmesg | grep 8960
[    3.613559] wm8960 2-001a: Failed to issue reset

i haven’t used linux regularly since before the advent of “modern” audio, so i’m a bit lost.

Usually a reboot gets the audio going for me if I see failed to issue reset (happens on booting from power off). Lukas speculates on a fix here and another person provided this line in order to rebind the device without a reboot:

echo 2-001a > /sys/bus/i2c/drivers/wm8960/bind

I was able to replicate the issue and test the above line out just now. I had to “sudo su” first. Then the audio device showed up in alsamixer again just fine.

thanks, this worked.

This worked great for me as well. Has anyone found the sweet spot for volume and distortion?

I’m using 83 on both alsamixer (exponential) knobs Speakers and Playback, which is shown as 96% on amixer (linear). That allows me to go to 100% on PA without (much) distortion.

ruff@reform:~$ amixer sget Speaker
Simple mixer control 'Speaker',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Front Left: Playback 122 [96%] [1.00dB]
  Front Right: Playback 122 [96%] [1.00dB]
ruff@reform:~$ amixer sget Playback
Simple mixer control 'Playback',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 255
  Front Left: 245 [96%] [-5.00dB]
  Front Right: 245 [96%] [-5.00dB]
1 Like

Seems to work well. Headphone performance is very good in terms of volume.