Sway and wayfire not working

New Reform user here, I too have broken my sway and wayfire.

I had it running briefly, but quit it and returned to bash to get the system all setup, files copied, external discs setup, etc. I did apt update and apt upgrade, and got errors; aborted the update without installing/upgrading existing packages.

debian unstable/main arm64.

serious bugs of libpam0g (1.5.2-7 → 1.5.3-7) <Outstanding>
 b1 - #1065425 - Does not upgrade from libpam0t64
serious bugs of libexpat1 (2.5.0-2 → 2.6.2-1) <Outstanding>
 b2 - #1064762 - Parsing of vtk files fails for files that worked previously (e.g. in bookworm)
grave bugs of locales (2.37-8 → 2.37-16) <Resolved in some Version>
 b3 - #1068737 - locales fails to install: locales failed to preconfigure, with exit status 2 (Fixed: glibc/2.37-17)
 libpam0g(1 bug), libexpat1(1 bug), locales(1 bug)
Are you sure you want to install/upgrade the above packages? [Y/n/?/...] n

The first sway problem popped up a red box complaining about line 28, the background image. I clicked “proceed” or launch anyway, and all I got was a grey-blue screen, time in upper right, “1” in a box upper left.

The mouse and clock worked, but keyboard did nothing; tried clicking on everything, ALT-F1 didn’t get me to my root screen (that I had setup prior).

I had no choice but to power off and fsck etc.

This time I did apt reinstall sway. This did not fix the line 28 background complaint. Edited sway config, the path was /usr/share/backgrounds/Sway_Wallpaper_Blue…; I found the reform-mountains.jpg file in backgrounds so I selected that. Ran sway. Now the background was correct, as per the first time, but keyboard locked up, this time I’d set up shutdown -r +10 but still had to fsck.

I did find existing forum thread “sway and wayfire stopped…”

…from back in early March. So I suppose I’m having the same issue.

lscpu says "aarch64, Cortex-A53…:

Here’s my apt log:

Start-Date: 2024-04-10  21:07:02
Commandline: apt install openssh-server
Install: libwrap0:arm64 (7.6.q-33, automatic), openssh-server:arm64 (1:9.7p1-4), runit-helper:arm64 (2.16.2, automatic), xauth:arm64 (1:1.1.2-1, automatic), openssh-sftp-server:arm64 (1:9.7p1-4, automatic), libssl3t64:arm64 (3.2.1-3, automatic)
Upgrade: openssh-client:arm64 (1:9.4p1-1, 1:9.7p1-4), openssl:arm64 (3.0.10-1, 3.2.1-3)
Remove: libssl3:arm64 (3.0.10-1)
End-Date: 2024-04-10  21:07:35

Start-Date: 2024-04-10  21:47:57
Commandline: apt reinstall sway
Install: libxcb-ewmh2:arm64 (0.4.1-1.1+b1, automatic), libdisplay-info1:arm64 (0.1.1-2, automatic), xdg-user-dirs:arm64 (0.18-1, automatic), wmenu:arm64 (0.1.7-1, automatic), libliftoff0:arm64 (0.4.1-1, automatic), libglib2.0-0t64:arm64 (2.78.4-6, automatic), libwlroots12t64:arm64 (0.17.1-2.1, automatic)
Upgrade: libxcb-icccm4:arm64 (0.4.1-1.1, 0.4.1-1.1+b1), libglib2.0-data:arm64 (2.78.0-1, 2.78.4-6), libglib2.0-0:arm64 (2.78.0-1, 2.78.4-6), sway:arm64 (1.8.1-2, 1.9-1+b1), libdw1:arm64 (0.189-4, 0.190-1+b1), libelf1:arm64 (0.189-4, 0.190-1+b1)
Remove: libglib2.0-bin:arm64 (2.78.0-1)
End-Date: 2024-04-10  21:48:18

Start-Date: 2024-04-10  21:48:56
Commandline: apt reinstall wayfire
Install: libwf-config1:arm64 (0.8.0+git20240312-1, automatic), libwf-utils0t64:arm64 (0.8.1-1+b1, automatic), libpng16-16t64:arm64 (1.6.43-5, automatic)
Upgrade: wayfire:arm64 (0.8~2023-09-11-gita85b274, 0.8.1-1+b1)
Remove: libpng16-16:arm64 (1.6.40-1)
End-Date: 2024-04-10  21:49:03

Start-Date: 2024-04-11  02:42:57
Commandline: apt install pmount udisks2
Install: pmount:arm64 (0.9.23-7.1)
Upgrade: udisks2:arm64 (2.10.0-5, 2.10.1-6), libudisks2-0:arm64 (2.10.0-5, 2.10.1-6)
End-Date: 2024-04-11  02:43:08

Any suggestions?

If your sway config talked about /usr/share/backgrounds/sway/Sway_Wallpaper_Blue_1920x1080.png then that sounds like you did not use the Reform sway config. Do you want to use the default MNT Reform sway config? If yes, you can restore the vanilla version by running:

cp /etc/skel/.config/sway/config ~/.config/sway/config

You could also try running reform-check as the normal user and see if it prints anything funny.


My silly mistake – I had managed to delete ~/.config in my various messing about during set up of the new machine. Restored that and all is well. Thank you. (I had been looking at /etc/sway/config).

Problem solved.