Trying to update Trackball Firmware

I’m trying to upgrade the firmware of the trackball in my Reform, hoping the upgrade will resolve bad (and at times, none,) tracking of trackball movement.

Note: I did fiddle with the right mouse button due to some self-inflicted problems that I was able to resolve and I hope that didn’t break anything.

I follow Parts — MNT Reform Operator Handbook documentation and did the following steps:

  1. Clone the reform git repository
  2. cd reform/reform2-trackball-fw
  3. make
    Here I get an error about avr-gcc not being present. Therefore I did
  4. apt install gcc-avr
  5. make
    This time the command finishes succesfully.
  6. Toggle switch SW7 on the trackball controller to “ON” press the reset button SW6.
  7. ./
    It says that dfu-programmer command is not found.
  8. apt install dfu-programmer
  9. make
    Guess I would not have needed to do this again, but whatever :smiley:
  10. ./
    Says “dfu-programmer: no device present.” 3 times as output

What is the problem here? The flash script targets atmega32u2. Is my trackball simply another device?

Also I can’t find “Atmel DFU bootloader” which the trackball should appear as according to the entry in the handbook. lsusb finds these devices
Linux Foundation 3.0 root hub
Linux Foundation 2.0 root hub
Texas Instruments, Inc. TUSB8041 4-Port Hub
Linux Foundation 3.0 root hub
Raspberry Pi RP2 Boot
Atmel Corp. LUFA Keyboard Demo Application
Texas Instruments, Inc. TUSB8041 4-Port Hub
Linux Foundation 2.0 root hub

If I recall correctly, there’s 2 revisions of the hardware. On based on Atmel and one on the Raspberry Pi micro controller. Firmware update is only for the Atmel based version. Have a look at the circuit board, do you see a raspberry print on a chip? :slight_smile:

This might seem silly, but have you removed your trackball to check that nothing is obstructing the sensor?

You are right, I do have the Raspberry one.

I did and it seems fine to me. After reassembling it worked fine. Then after just idling for a while in sway with only the initial terminal open, problems occur again. That is, mouse hardly moves, sometimes it moves a bit. I can get the sensor to react by doing things like moving other objects then the ball close to it.
Here are some photos of my trackball module in its current state. Maybe it helps.

Seems like maybe the sensor is defective. Maybe contact MNT and see what they suggest.

Also, sometimes the sensor looks fine but actually isn’t. I solved my own problems of the trackball not functioning anymore by blowing onto the sensor with my mouth really strongly.

Here is an update.
I fiddle with the trackball and sensor and found out that when I tilt the sensor, the tracking works as expected.

I realized this by not turning the screws all the way. The force applied by the connector between the sensor and the board does the rest.

I wonder if that what it was like when the laptop came and I just mindlessly tightened the screws lol.

This is a picture of the tilted sensor.

Also, best new years eve wishes to everybody

Hi, these issues do not seem normal. We are checking via support if sending you a new sensor module might fix the problem.