Unable to get ZZ9000AX working

Fresh install of Amiga OS3.2 on 500GB IDE/ATA disk.
All latest drivers for zz9000 and commercial P96 drivers.

  • Amiga model: A4000 desktop
  • 680x0 CPU: FastlaneZ3 060
  • RAM Configuration:fast 52Mb + ZZ9000-256Mb
  • Kickstart, AmigaOS Versions: Kickstart 47.96=3.2 / OS 3.2
  • ZZ9000 Firmware version: * [ZZ9000 Firmware 1.10 BOOT.bin for Zorro 3]
  • ZZ9000 Driver version: * [ZZ9000 Amiga Driver Installer Package 1.10
  • Monitor model: Asus VG-series HDMI
  • Other Zorro cards:No

I have Installed AHI v 4.18, Powercycled and configured ZZ9000AX as my soundcard Unit 0, but i always get it to crash/freeze as soon as for example AmigaAMP tries to use unit 0. I have gotten AHI 4.18 to work with built in Paula Sound but never zz9000AX.
With AHI V6 on the other hand is stuttering as expected but atleast it is working somehow compared to 4.18 that seeems impossible to get to work at all.

Anyone have any idea of what could be done to mitigate this? IS there some test i can do to see if somethings broken or faulty connected?
I have very carefully gone through the connections several times so i think everything is properly connected though and it seems to work (with Stutter) in AHI 6.
Sincerily

Tried an mp3 with AXmp3, i only got a short pinknoise and then it stopped with this break and the graphical bug as seen. The amiga is responsive and havent crashed.

Swapped to AHI 6.0 just to show the card seems to be working someway.
Still i get Graphical bugs as seen in top of Monitor using p96.V3.2.4 but it plays in AmiAMP and seem to send the data to the device anyway.
When i tried AxMp3 i get the same error an when i tried under
AHI4.18

Yes I have this problem too …

1 Like

Stumbled on to this mastodon thingy:
image
I tried the axmp3-32meg, still no sound but now without the graphical bug.

A4000D, 2 chip, 16 megs on board and 256 via ZZ; AOS 3.2 with kicks and FastATA. ZZ driver/firmware version 1.10 and AHI v4.18 (the one which was recommended)
I just installed ZZ9000AX and tested the mp3 (6 Mb file/192 kbps) and it was no go (the same issue as @Silver), so I restarted the system. There is still problem with the drivers where system will guru during the boot, but after the LMB click, it will boot to Workbench. I tested the mp3 again and it was working.

mp3 file working

Image reflects my AHI setup.
image

The installation of AHI drivers was fine until to the point where I was supposed to pick sound card. I just left it as is, as nothing was referenced in the manual. That was the only confusing part I found during the whole process.

I am not sure why is it working for me, but I just wanted to report that it is.

Cheers!

edit: spelling+typo

2 Likes

Hi Levellord,
Thank you for you feedback.
What kind of CPU do you have? might it be a 030 ?
I have 060 and i suspect most people with this problem seems to use 060.
I have never had any problems to boot with Firmware 1.10 and AHI 4.18, it just dont play any sounds at all until i switch to AHI 6.0 but then i have glitches/distorsion/stutter instead.

Hey @Silver!
Amiga is 040 NTSC with FPU, I forgot to mention that. Firmware and drivers I installed are autoboot + fastram enabled. Let me know if you need anything else, I’ll help if I can.

@mntmn Any progress regarding this issue or was it a tough one to solve?
Please dont hesitate to ask if theres any thing we 060 owners can do to test/help/troubleshoot this issue.
Regards /Silver

Hi all of you who are having this problem! I couldn’t reproduce it so far, but still trying. I also tested with A2000/040 today (PP&S card) and it worked absolutely fine.

Does the situation get better for you with the driver (zz9000ax.audio file copied to Devs:AHI) from this archive: http://dump.mntmn.com/zz9000ax-ahi-tw.lha? (Edit: link fixed)

One more thing: several people that had no audio output had the cable to the MIO header on ZZ9000 in the wrong orientation. Can you confirm that this cable is connected properly?

Thank you Mntmn, checked all cables again and i thing they all are in order.
Heres are some shots to confirm.



I have tried to follow the link to https://dump.mntmn.com/zz9000ax-tw.lha
But when i klick the link i just end up here:


Is it a typo and it should have been zz9000ax-ahi-tw.lha ?
You posted this file for 3 days ago but in that archive i can not see any containing file named “zz9000ax.audio”.
Opening the archive gives me these files. (atleast when i open them on pc)
image
Regards /Silver

Another edit, after i posted the images i now see the file “zz9000ax.audio”, damn dementia ;-D Im gonna try adding that to Devs:AHI and report it’s outcome.

1 Like

Running AHI 4.18 (installed the 060 version) and with the exchanged file zz9000ax.audio in devs:AHI
i kind of get it to work. Sometimes it crashes with guru, sometimes it seems to work/boot without crashes but when i play something i get stutter like when i use AHI 6.0. Im gonna experiment with different modes 24Khz-48Khz and with different softwares during the day and tell my experiences.

I have now experimented with AHI 4.18 for 060 processor and the modded zz9000ax.audio in Devs:AHI. When i boot the machine it sometimes hangs/crashes, sometimes i have no sound at all and when my screenblanker starts running it goes really slow indicating the zz9000 GPU is working hard with something. Sometimes it works more or less the same as when i run AHI 6.0 as you can hear in this video.
So depending on the restart of my Amiga, i get a pretty mixed experience of all of the above :confused:
Here is when it boots without crashes but the dropouts and stutter is still present. Forgot to mention that i have tried all modes between 8Khz up to 48Khz with more or less same results so dont think it’s a performance issue.

Hi,

glad you made it work. The stuttering in the playback sounds like the CPU is overtaxed by decoding+resampling the MP3 on time.

Can you try playing one of those MP3s using this tool (CLI) instead: http://dump.mntmn.com/axmp3-32meg (you will need to use PROTECT +E on the file after downloading)

The music i played in AmigaAmp is streamed MP3 also known as Shoutcast. I have no problems to decode/resample it up to 44.1Khz Stereo and send it to Paulachipset without stutter.

Here is my test of playing Mp3 through Axmp3-32meg. It’s is not possible as you can se here: when i play the file sample-15.mp3

I also played the same mp3 in amiamp where i have set AHI to 11Khz and Amiamp itself to 11Khz, same stutter.

1 Like

OK, this is getting very interesting, thank you. Could you email me the MP3 file (sample-15.mp3) to lukas@mntre.com so I can check what’s up with axmp3?

Also, could you try playing this WAV file in SongPlayer 1.62: http://dump.mntmn.com/sweep24.wav

Please enable AHI and set Mixing to “Off” in Audio/AHI settings of SongPlayer. Make sure that AHI Music unit and Unit 0 are set to 24KHz in AHI Preferences.

Sent you my test mp3 file via mail but any mp3 file or stream (shoutcast)play the same as far as i have experienced.
For the next test: AHI music/unit 0 set to 24Khz and rebooted.
Song player is set to Mixing OFF.
I hear snaps/cracks/pops/stutter while the sweap is played.

Thanks everyone for the testing and feedback. I fixed several show-stopping bugs over the last days and here is a new beta firmware and driver for you to test (also includes a new ethernet driver):

http://dump.mntmn.com/zz9000-fwpack-110-20220429.zip

The included BOOT.bin-z3-20220429 needs to be renamed to BOOT.bin and placed on the MicroSD card that goes into ZZ9000.

Please be aware that this version is only for Zorro 3 machines. A Zorro 2 version will follow after this one is confirmed working.

1 Like

Thank you for your efforts Lukas! Now finally i can listen to 16Bit 44.1 Khz :smiley:
I have tested Axmp3-32meg successfully. I have Tried several AHI enabled players like Eagle player/DeliTracker/Songplayer and my favourite AmigaAMP with Streamed Shoutcast/internet radio and they all work now.
Might it be possible to tweak Axmp3-32meg so that it would work as a Hardware “MHI” driver? Now AmigaAMP needs 060 in order to decode the data by software.

Here is me playing around with new firmware, im very happy with this.

2 Likes

Thanks for the feedback! We now have a new release ready: