Wifi range issue

The wifi on my Reform cuts out when I get more than around 10m away from the access point. It makes me wonder if the antenna is even connected, but I just disconnected it and reconnected it, and it seems to be seated well.

The following shows up in dmesg:

[ 10.548017] ath9k 0000:01:00.0 wlp1s0: renamed from wlan0
[ 12.062635] wlp1s0: authenticate with 08:26:97:77:47:40
[ 12.086824] wlp1s0: send auth to 08:26:97:77:47:40 (try 1/3)
[ 12.098214] wlp1s0: authenticated
[ 12.107287] wlp1s0: associate with 08:26:97:77:47:40 (try 1/3)
[ 12.120879] wlp1s0: RX AssocResp from 08:26:97:77:47:40 (capab=0x401 status=0 aid=6)
[ 12.132848] wlp1s0: associated
[ 12.140466] IPv6: ADDRCONF(NETDEV_CHANGE): wlp1s0: link becomes ready
[ 12.210967] wlp1s0: Limiting TX power to 30 (30 - 0) dBm as advertised by 08:26:97:77:47:40
[ 12.418188] wlp1s0: deauthenticating from 08:26:97:77:47:40 by local choice (Reason: 3=DEAUTH_LEAVING)
[ 14.853591] wlp1s0: authenticate with 08:26:97:77:47:40
[ 14.879353] wlp1s0: send auth to 08:26:97:77:47:40 (try 1/3)
[ 14.890702] wlp1s0: authenticated
[ 14.903329] wlp1s0: associate with 08:26:97:77:47:40 (try 1/3)
[ 14.917097] wlp1s0: RX AssocResp from 08:26:97:77:47:40 (capab=0x401 status=0 aid=6)
[ 14.929334] wlp1s0: associated
[ 14.937076] IPv6: ADDRCONF(NETDEV_CHANGE): wlp1s0: link becomes ready
[ 14.975884] wlp1s0: Limiting TX power to 30 (30 - 0) dBm as advertised by 08:26:97:77:47:40
[ 421.014786] wlp1s0: deauthenticating from 08:26:97:77:47:40 by local choice (Reason: 3=DEAUTH_LEAVING)

In particular that last line is questionable since I never made any “local choice” to disconnect.

Another strange thing is that my preferred wifi access point shows twice in the gnome wifi listing; once normally and once with " - Failure" appended to it.

Hmm, this can be a number of things. What comes to mind:

  • You could swap the antenna connectors
  • You could change the channel on your router/AP
  • You could try to setup/change the regulatory zone (search the web for iw reg set)
  • In general the iw tool can give you a lot of information
  • You could upgrade to the Laird EFD2455A3S-10MHF1 antenna
1 Like
You could upgrade to the Laird EFD2455A3S-10MHF1 antenna

I just installed this, and wow! It makes a huge difference; I can use wifi in any room in my house now. Highly recommended. Thanks for the tip.

7 Likes

This is good to know, thanks!

I also had issues with range and connection stability, but swapping the antenna connections has improved my experience.

2 Likes

I’ve been having a lot of trouble with wifi, too. I tried switching the antenna, reversing the connections, but it would still get disconnected frequently, even when it was pretty close to an AP.

I think I may have fixed it by uninstalling connman in a fit, and only using nmcli to switch networks. I can’t explain why this is true, but after 24 hours of working wifi, I’m willing to declare victory. Maybe connman is too magickal for its own good?

So if you’re reading this thread because your wifi seems flaky, try switching to nmcli and turn off connman.

I had a similar problem when my “bootstrap a new system” scripts pulled in network-manager; I think connman and network-manager were fighting over control of the device and would frequently disconnect. In my case I solved it by removing network-manager; I think the main thing is just to ensure that you don’t have both. connman on its own has been fine for me.

I’m having no end of trouble with the wireless card. I’m currently tethered to my phone, which is right next to me, and I’m getting 57% signal strength. Best I’ve seen is 60%, right next to the router downstairs. If I leave the room, the connection drops.

Is the stock antenna really that bad? I’ve tried swapping the UFL connectors to and fro, and it’s made no difference.

I also don’t seem to be able to connect to any 5GHz networks: my router doesn’t show up in the scan at all, even if I’m right next to it, and if I switch my phone’s hotspot to 5GHz it appears in the scan but times out when I try to connect.

I’ve set my regulatory domain to GB, so that shouldn’t be the problem.

Aside from replacing both the Wi-Fi card and the antenna, any ideas for something I can try to make things a little more usable?

Sounds like an antenna and/or interference issue to me. I personally use the Laird EFD2455A3S-10MHF1 and it works fine with 5GHz networks. Also, two users of the beta version modified the side panel so that they could mount an external SMA antenna for extra strong reception.

If it’s interference, it’s exclusive to the Reform - because every other device in the house connects fine.

I’ll look into a replacement antenna - the Laird EFD2455A3S-10MHF1, sadly, is not easy to get hold of in the UK so it’s looking like I’ll have to import one.

I like the idea of a pigtail to an SMA on the side panel for an external high-gain, but I’d worry about longevity: the thin side panels are brittle, and if anything caught the external antenna I have no doubt the panel would break.

Ah yeah, that’s another topic. Since a while I wanted to try to make alternative side panels from aluminum or better, steel. But I haven’t got around to it yet. If someone here feels enterprising, these are the drawings:

Edit: There are several services on the net that can lasercut sheet metal. Some need a 3D model though, so these drawings would have to be extruded to a 1mm 2.5D model.

2 Likes

The regulatory domain can still be the problem, if you look at iw reg get you’ll probably see that there’s two domains, the GB you set and a world one hard coded into the card. Though this would be common for that card in any laptop and not just the Reform. On my fork of the reform-system-image I’ve got a branch with some of the openwrt patches to override the internal REGD entry of an ath9k card so that you can manually set the domain with iw reg set GB, or better with crda.

Though in the default one it should still be able to connect to a 5GHz access point that’s broadcasting, even outside the world bands.

1 Like

Something you can try is mounting the antenna closer to the acrylic base. (Assuming you’re using the Molex one of the acrylic). Add some spaces below it, or use some kapton tape or such to tape it to the base and see if that improves. That’d move it farther away from the circuit board, which is part of the point of the acrylic mount anyways.

Other thing to check is try swapping the two antennas.

Another type of antenna you could look for is one salvaged from a laptop. You can typically find thin narrow ones designed to go beside the LCD in them, and then mount them either side against the side panels.

1 Like

What does the order of the antenna connections do? I’ve been told by friends much more knowledgeable than me that it should definitely matter…

They’re just two antennas, the ordering is not important. Perhaps there are some laptops where they have a larger main antenna and smaller aux, but if you’re connecting all of the antenna connectors it’s not an issue. The molex that comes with the reform is simply two antennas, as is the Laird. It should make no difference as to the order. If you wish you can test performance with both orientations, but it shouldn’t make a noticeable difference.

Some wireless cards will just label them as they are, channel 0, 1, (and possibly 2).

But looking at the traces on the included molex antenna, it seems that they are different, one looks larger than the other.

Perhaps you’re seeing the two parts for 5ghz and 2.4ghz?

Just looking at the datasheet https://www.molex.com/pdm_docs/as/2084820100-001.pdf In their testing they call the left cable as Port 1 and the right as Port 2 (assuming you’re looking at it with the cables pointed down). And port 2 ends up with a slightly higher gain (which means it’s a bit more directional.

If you scroll down to the radiation patterns for 2.4GHz you can see the patterns are fairly similar, with port 1 having a front to back (side with the antenna wires poking out and the opposite) directionality. With 2 having it more in the left to right direction.

From the data I’d personally use port 1 as the “main/channel 0” antenna as it’s more omnidirectional of the two with less “spiky” nodes. As well as having stronger transmission in the X-Z direction (up and down).

Though really it shouldn’t make all that much difference if you’re connected to a 2x2 antenna router where you’re using both antennas equally for 2x the data. (Wireless N 300).

3 Likes

I’ve got my antenna wired up this way and am likewise experiencing flaky wifi. I’ve ordered a Laird EFD2455A3S-10MHF1 and will report back regarding whether it makes a significant impact or not.

FWIW, I have also had slightly better luck with NetworkManager than I did with connman.

Something I’d try is tape the acrylic mount up to the acrylic back of the case so the antenna is as far from the PCB as possible, and see if that makes any difference. Curious if more distance would help it there. Or some other way of spacing it from the board

First full day of using the Laird antenna. Going to keep it in place for the next week or so before I make a judgment, but so far it actually seems slightly worse.

Once I’ve got a good sense for which seems to be the stronger antenna, I may start experimenting with placement.

Edit: Day 2. I’m definitely seeing weaker wifi signals with the Laird. Contrary to what I wrote earlier, I’m not going to go a week with this antenna in. Next I’m going to see if I can mount the Molex antenna to the back of my screen by feeding the wires through the opening on the inside of the hinges. Putting the antenna on the acrylic seems like it’d make removing and replacing the bottom a bit difficult, to be honest. If that doesn’t produce acceptable results, then I might try experimenting with ways to externally mount a pair of wifi antennas from an old router I’ve got on hand.

Edit 3: Molex antenna wires aren’t long enough to reach the wifi card from outside the case. Going to try another laptop antenna entirely. Will report back when it arrives.

1 Like