Will we be able to USB power mnt reform?

What is the wattage of the charger you used? I’ve had success with a variety of 65W chargers and a 45W charger.

Apple doesn’t publish the details of supported voltages for their chargers, but a 30W charger would only be able to push 1.5A on a 20V connection, so it doesn’t suprise me too much that it wouldn’t work. It’s more likely a 30W charger doesn’t even support a 20v connection, but I can’t be sure because Apple doesn’t publish that information directly.

As an example of what to look for, check out this Anker 65W charger. Under specifications it lists “Output 5.0V==3.0A /9.0V==3.0A / 15.0V==3.0A / 20.0V==3.25A” so I’d expect this one to work. My go-to charger is the Pinepower Desktop and it lists “5V3A, 9V3A, 12V3A, 15V3A, 20V3.25A” as well.

Thanks for the info.

Written on the macbook charger is:
(USB PD)Output: 20.3V == 3.3A or 15.0V ==3.0A or 9.0V == 3.0A or 5.2V == 3.0A

I also tried with a “Anker PowerPort III 65W Pod” which according to Amazon is the same output as the one you linked:
Output: 5V/3A, 9V/3A, 15V/3A, 20V/3.25A
I do not get any red light with it, not even flash, with either cable.

I have another USBC adapter that stopped working earlier (no red light at all), but perhaps it is the Reform that’s having problems. I have some replacement adapters in the mail that I will try later to confirm.

You even need to check the cables, some are only rated for 3A.

An update on my USB adapters, all tested through the 65W Anker power supply I mentioned above.

Originally I had been using this adapter for a few months, but then it died. Surprisingly, now that I have a replacement, it has come back to life.

This one works fine, has a standard plastic cable. Some metal around the USBC end, plastic around the barrel.

This one is also fine. Has metal around both the USB and Barrel ends, and a threaded cable.

This one from the same seller as above was dead on arrival. Disappointing as it was the most fun connector.

And I tested both of my Adafruit cables again to be sure, and they continue to not work.

1 Like

Just a little note on my USBC experience. I don’t think the adapters like being under load when initially powered on. The red light in the reform will come on and turn off right away.

This happens for me when plugging in when the batteries are not fully charged.

To correct this, make sure the adapter is powered first before plugging in the barrel connector. You may also need to power cycle the adapter first.

1 Like

It depends on USB charger, but approach proposed by you is safer. Some chargers and adapters I used were able to start charging after connecting to mains, but not all of them. OTOH I never had problems when I was first plugging in charger and only then connecting USB adapter.

1 Like

I tested both AdaFruit cables (mentioned by @khm above) and Amazon adapter from second post of this discussion.
I used Green Cell charger (GaN Charger GC PowerGaN 65W (2x USB-C/PD, 1x USB-A QC 3.0) ). I was able to power MNT Reform with 9V, 15V, and 20V (AdaFruit is out of 12V cables :slight_smile: ) - power management is really impressive!

I was even able to power 2 laptops at once (second was MacBookPro); charging was rather slow in such a case, but both laptops were charging and not discharging, although I was not doing intensive work at that time (mostly web, some text and ssh to remote machines).


does anyone have experience of using this sort of thing so that they can top up the machine from one of the usb ports you see on a plane these days?

Do planes offer USB-C ports currently? I’ve only seen USB-A, which is limited to 5V, so you cannot power your laptop from it. And even if they offered USB-C, it would need to be PD (Power Delivery), able to provide 20V @ 3A (i.e. 60W) to be able to use those cables/adapters.

yeah I saw one on a quantus flight from australia to new zealand this year

Not relevant to USB-C, but I’m curious if one of these 5V->12V step-up adapters (Amazon link) could allow you to charge the device on a plane.

I have tried one of these. But as expected they charge really slowly only. I was only able to get some charge into the reform by having it powered off over night. I wrote about this a few posts above:

1 Like

Another data point: Originally I had bought the short adapter cable suggested by Lukas:

In the article description you see that the barrel jack is compatible with 2.5 as well as with 2.1 inner diameter. The reform barrel jack has an inner diameter of 2.1 mm and consequently, this usb-c adapter fits but it is very easy to remove and wiggles a bit. It feels like it could fall off any moment and is very easy to pull out.

So now I tried this one:

This adapter comes with 2.5 or with 2.1 mm inner diameter. I bought the variant with 2.1 mm inner diameter and this barrel jack now really fits very nicely into the plug. It’s still easy to plug in and remove but it doesn’t feel anymore like there is any wiggle room. I also like this adapter because it’s not a cable and thus quite a bit smaller and easier to carry around when traveling.

But both adapters do their job perfectly well.

Does someone have a source for that cable, that is not Amazon?
For various reasons, I don’t have an account there, and don’t want one.
Alterantively, any other solution to USB power MNT reform.


I’ve bought cables from AdaFruit, mentioned by @khm in this thread on 2022-08-12. Any of them (i.e. 9V, 12V, 15V, and 20V) can be used to power MNT Reform - and I used 20V one to power Purism Librem 13. But they sent packages from USA, so if you are from EU, post costs can be quite high - possibly even higher than cables/adapters if you order only them.

1 Like

Thank you @serpent! adafruit have a European distributor, Mouser, so it should be easy, even if expensive. (20 € for shipping)

It seems that delock sells what the reform needs to usb power it but I haven’t tried these out myself yet. The website lists where to buy it by country:

And I found this one:

1 Like

I absolutely sympathize with this sentiment. So to promote some non-amazon source, I tested out the two Delock products that I mentioned in my last post and which can be bought from several non-amazon stores. One can either use the delock.de links above to find sources or price comparison sites like geizhals.at to find them. I bought them at jacob.de.

The 5.5/2.5 mm barrel jack adapter as well as the USB-C cable work just as advertised with my reform and are able to charge it with my 60 W usb-c wall plug.


An update on my own experiences, I’m somewhat sure there is something wrong with the power on my board since things don’t work for me like they seem to work for others.

  • The adafruit cables never worked.
  • When plugging in to a “high power” USB-C charger such as a macbook power brick or two different 60W Anker adapters, using a usbc to usbc cable, and the batteries are fully charged, it seems the corner of the laptop gets hotter than I would expect.
  • When the reform is running, and the batteries are partially discharged, and I plug one of the above in, the red light will blink (at different rates for different cables and adapters), and i don’t think any charging or powering happens.
  • When I plug a UsbA to UsbC cable in, while the Reform is on, I’m able to power it, but no charging occurs, and no red light.
    This also seems to run cooler than when running a usbc to usbc cable.
    After I shutdown it will then slowly charge back up.

I have no problems with the power brick that shipped with the reform, I’d just like to use my smaller adapters for travel.

Edit: in hindsight I don’t think the temperatures feel any different between the different cables

Sorry for resurrecting old thread, but I think it’s better to keep related topics together.

Recently I have similar problems with USB-PD. Normal charger (24V, with barrel-jack) works, and OLED shows around -1.4A when charging. When it’s connected, red LED D8 shines; when batteries are full, D9 also shines, but it stays off during charging.

But when I connect AdaFruit 20V cable, MNT Reform is not charging. I tried 2 different cables, so I treat failure of them as low probable. OLED shows no external power, and 0.0A. D8 initially is on, but after few seconds starts blinking. I tried to analyze firmware, but haven’t found code responsible for LEDs. Not sure if it’s there, or if they are managed by hardware.

What makes it strange: I tried 15V cable and it was working! It started charging, LEDs were on. OLED was showing -0.5A; lower than with normal charger, but IMO still usable.

Don’t know yet what to think about that. I’ll be trying different combinations and should let you know if find something interesting. If someone has tips regarding firmware, please share. At the same time, this is not project with high priority, so I’m taking care of it in free time.