ZZ9000 Network not working


I’m trying to get my ZZ9000 to connect to my router. Using roadshow, I can see in the log that it just times out waiting for a DHCP answer. If I specify static address, it looks like it’s connected but the router says nothing is using that IP and I can’t even ping the gateway from Amiga

It was working, then I reinstalled Workbench and it stopped.

I’ve also tried AmiTCP (as EasyNet) which says it’s connected (static IP) but nothing transfers. Tried MiamiDX, similar - “Online” but cannot ping.

If I swap to a USB Ethernet adaptor on the Freeway, it works fine - DHCP via Roadshow, downloads at decent speed etc. So it feels like an issue with the card, or with ZZ9000net.device

Are there any diagnostic tools?

If you want to ask a technical support question, please include the following details. If not, you can delete all of this text.

  • Amiga model: A4000
  • 680x0 CPU: 68060
  • RAM Configuration: 2+16MB+ZZ9000
  • Kickstart, AmigaOS Versions: 3.2.1
  • ZZ9000 Firmware version: 1.9
  • ZZ9000 Driver version: 1.9
  • Monitor model: n/a
  • Other Zorro cards: Freeway Pro


could you try with this new Test Firmware and the included ZZ9000Net.device driver?


Edit: The included BOOT.bin-z3-20220429 needs to be renamed to BOOT.bin and placed on the MicroSD card that goes into ZZ9000.

Hi, apologies - I realised there was a mismatch between driver and firmware. I didn’t use the link you posted, but I did upgrade everything to 1.11 and that got it all working. I think I’d restored the wrong backup of my CF card and it was an older driver.

Sorry for the very late reply, hopefully this is useful to anyone else with the issue - check the firmware matches the driver!

1 Like