ZZ9000 problem (corrupt screen AGA and RTG)

Hi ZZ9000 owners

I have been using my ZZ9000 on/off for the last 2 years and it has worked flawless, until today :weary:

The issue is that the card only shows a corrupt screen and then freezes. It dos this on the scandoubler, and on the RTG side it’s only a black corrupt screen.

Here is what I have done to try and “fix it” (and that did not work):

Taken my A4000 apart, and cleaned all the connectors (even the Buster-11 pins).
Updated the firmware to the latest 1.13 (even tried downgrading to 1.8) all Zorro-III.
Taken all cards out except the ZZ9000.
Taken the FPGA board of the ZZ9000 and cleaned the pins.
Removed all HDD, ODD etc.
Cleaned all RAM pins.

None of that worked.

The board is only 2 years old :cold_sweat:

My setup:
A4000D Rev.B, CyberStormPPC 060@50HMz/604e, 128MB RAM, 2MB Chip, Kickstart 3.1
ZZ9000 R3

Any ideas to what is wrong or ideas to fix it?

Kind regards
Michael

Hi Michael, I’m sorry to read about this issue. I haven’t yet seen the failure mode in your screenshot. Is this an R-3 card or an older revision? If older, was the 1.8V fix done? Also, please contact support@mntre.com about repair/inspection options.

Yes, It is rev. R-3 (2020-09-17). (It was shipped from you 2022-02-17)

Might it be the RAM on the Zynq board that has a defect in it?

What options do I have to find if the Zynq board is at fault? Do you have a “stand-alone” OS or program to run from the SD card port, to see if the board works?

Indeed there’s a new work-in-progress diagnostic firmware that you can try, I will upload it tomorrow. As for the ZYNQ module, you could be right. You can get a replacement from Mouser or MYIR if you don’t want to go through our support process.

1 Like

Hi again

I can’t find the diagnostic firmware. Can you please link to it?

I guess there never was a diagnostic firmware available for this board. :frowning: