Zz9000 zorro 3 boot problems

  • Amiga model: A4000D
  • 680x0 CPU: 68060 Rev 5 BFG9060
  • RAM Configuration: 2MB Chip, 16mb Fast, 128MB BFG9060
  • Kickstart, AmigaOS Versions: 41.111, 47.4
  • ZZ9000 Firmware version: 1.13
  • ZZ9000 Driver version: 1.13
  • Monitor model: LG 4k TV
  • Other Zorro cards: None

If I use any Zorro 3 firmware my A4000 refuses to boot, the power light flashes and it goes into an endless reboot cycle.
I discovered if I use the Zorro 2 4MB firmware everything works fine.

I have tried all the suggested solutions IE. reseating Roms, Ram, CPU card. reformatting SD card, nothing works.

Any final solutions ?


Does your 4000 have the superbuster 11?

Yes, its 390539-11, 45-super buster

Hi Dave, could you try a different SD card? Sometimes it’s a timing issue.

Just tried a Sandisk 16GB card in it and unfortunatly no change with the base firmware, but the NOAUTO give me an error

This seems like exactly the problem I had and solved by reformatting the SD card and putting the firmware back on…

Did a full format of the SD Card, but no joy. I have ordered 8GB card
see if that make any difference, but Im not holding out much hope.

Just used Q-connect 8GB sdhc card, and this card is not even recognised, (so not recommended). Ive used sandisk and kingston and the ZZ9000 exhibits the same problems

1 Like

ok, added a new riser board from amigastore.eu, a new kingston 8gb SD card, and the same thing happens power LED flashes and the machine goes into a reboot cycle. Totaly lost now.

Hi again,

I’m sorry to hear about this bad experience with the ZZ9000. Typical advice we give is to reseat the Zynq module, change Zorro slots, make sure your power supply is good. But if nothing helps, you can return the card for a refund or free inspection/warranty repair. For this, just contact support@mntre.com for the info about sending it in.

What format is your SD card formatted in FAT or FAT32? I had a similar issue and found that the SD card was shipped with it formatted in FAT and not FAT32. Mine was doing a similar thing of the power light flashing weird and getting the RED screen. I formatted mine in a Windoze 10 machine and added 1.13 boot.bin. It has been stable since.


Its FAT32, i’ll prep a windows 10 machine see if it makes a difference to the formatting.

My SD has 256Mb and is formatted Fat, not Fat32.

After a lot of trial error, It would appear to a problem with a A4000
Just added a Freeway Triton USB card and that will only work in Z2 mode.
I think I have a dodgy Buster chip

It was shipped to me in FAT but their documentation says FAT32. So I formatted it in FAT32 and my A4KT has been stable since.

Just did the scariest solder job ever, successfully removed the surface mount Buster 11 from my A4000, added a socket, droped in a new Buster 11 AND Z3 now works perfectly, now using my ZZ9000 too its fullest