ZZ9000AX with Audio-CDROM

Hi,
i’ve connected an audio cable of a CDROM to the internal AUX-connector of ZZ9000AX. It works but it is very quiet.
I can’t hear the sound from an Audio-CDROM together with normal loudness of Amiga. Either Audio-CDROM is too quiet or Amiga is too loud.
Will there be a volume control in future release of firmware?

  • Amiga model: A4000D
  • 680x0 CPU: 68060
  • RAM Configuration: 16MB (Amiga) + 256MB (Fastlane Z3)
  • Kickstart, AmigaOS Versions: 3.1.4
  • ZZ9000 Firmware version: 1.11
  • ZZ9000 Driver version: 1.11
  • Monitor model:
  • Other Zorro cards: Fastlane Z3
2 Likes

Same Problem, would be very nice to get the option to configure the volume of the cd input, otherwise it’s unusable for me.

@mntmn please answer :slight_smile:

Yep, same issue with low CD audio at the aux port for me.

1 Like

Hi, the problem is that these are mixed together with Paula audio on the ZZ9000AX in an analog circuit, so the volume of Paula vs AUX input can’t be regulated independently. Some solutions I have in mind:

  • A little preamp that goes in between CDROM and AX
  • Maybe a resistor can be changed on the mixer circuit on the board to change the levels

Edit: removed 3rd option because the jumper already connects to XAUD.

As you can see in the schematic here, XAUD (the CDROM input or the second set of RCA connectors) is mixed with AMI (Paula input) via this active mixer circuit. Tweaking R28/R31 vs R27/R30 should change the relative volume levels.