Poor browser performance

I realize accusing a browser of being slow is like complaining that ice is cold. But I’m wondering if my experience is as expected.

I’m having page load times in many tens of seconds, for very many pages. Of course some of them are awful commerce sites.

I compared four machines under conditions as similar as possible: Mac Powerbook Pro (M1 processor) (the ringer!), Pixel 7a running grapheneOS, an old Acer CB5-132T chromebook running current Debian (Celeron N3160 1.8 GHz, Braswell), and Reform, with imx8mq processor. Firefox on all, one page only, and that page is a browser benchmark site, https://browserbench.org/. All connected to a gigabit fiber via the same wifi AP.

Results, in the tests’ arbitrary units:

Powerbook: 13.0
Pixel 7a: 4.78
Chromebook: 0.717
Reform: 0.512

One random page here took 44 seconds to load:
https://www.summitracing.com/parts/urr-brc147

Interestingly, video plays fine, though I don’t care much about video, ironically.

Is this performance as expected?

If you mean this benchmark: Speedometer 3.0 then on my Reform with A311D I get a 1.52. Browser performance is greatly improved with the A311D compared to the imx8mq. I remember that with the imx8mq, some youtube videos would take 30 seconds before they started playing. So I was usually using clapper and gtuber to watch online video like YouTube and Twitch on my imx.

1 Like

Yes, speedometer 3.0.

OK good then. I have A3111D on order since 18 april hopefully it will ship soon.

1 Like

Hi there! While you wait, you can also try Chromium in the meantime, it should be a bit faster on imx8mq. The company was basically struck down by COVID-19 and a move of my colleague this last week. Shipping will be resumed in the coming week. I will make some coffee and get the score of RK3588.

OK, here are my Speedometer3.0 results on MNT Reform with RK3588:

  • Firefox Nightly (127.0a1 / 20240424154624): 4.0
  • Chromium (123.0.6312.122): 3.83

Edit: The summit racing page takes around 3 seconds to load in Firefox.

1 Like

Impressive, the difference is barely less than a second. Seems firefox hasn’t lost its speed yet.

By any chance are you using arkenfox? Or did you manually disable the telemetry parts of firefox to achieve that result?

If you did neither, that speed can be improved on I am sure.

@minute I saw on the fedi you got the eeevil virii. So sorry, do whatever you have to do to get well! The board will arrive, my slow browser is not an emergency.

Yes, that Summit page for a silly washer is slow, they have a very slow backend. It’s about 2 seconds on an M1 Powerbook Pro.

@shockwave I wasn’t aware of arkenfox, will look at, thanks.

tom

1 Like

I don’t have done any test because I don’t care, but A311D put my Reform to another level. All seems working seamless, I really enjoy it! Fun fact: CPU is a lot cooler with this new CPU, never go beyond 51˚C and in general around 45˚C.

On my IMX I was using qutebrowser which work not so bad with a clear minimalist interface

1 Like

I’ve tested a few devices I have access to for comparison but I’ve currently borked the install on my reform playing with wine and box86/64. Haven’t had time to get it booting properly.

All running firefox
Raspberry Pi5 - 4.08
Old Dell XPS 13 (i7 6550u I think) - 2.12
Framework (i7 1280P) - 7.07
Steamdeck - 8.24
Work PC (i7 9700) - 5.83
Pinebook Pro - 1.09
Pixel 7 - 5.27
Mini gaming PC (5900HX,6600M) - 11.72

None of these ratings really corresponded to how fast browsing felt. The old XPS 13 with a score of 2 felt faster than the pi5 which scored twice as high. I saw that the reform with the a311d scored about a 1.5 and that only feels marginally slower than the pi5 and much slower than the xps. To me any of the x86 systems with a 2 or better felt fine while arm at 4 was where performance started to feel on par.

1 Like

Did you run your ARM systems from an SD-card? Firefox is reading and writing a lot of data to its various caches and databases every time you click on a link or start typing in the address bar.

I absolutely second this. I just just had a presentation for a job interview which I did from my Reform as I feel that with the a311d, the Reform became just a “boring laptop” in the sense that things just work, so I have no worries when using it for serious stuff. :slight_smile: I’m so happy with the a311d, I might buy myself a second-hand one from those people who are upgrading to rk3588. :grin:

1 Like

tbh I wouldn’t trust those benchmarks in the first place. It can give you a rough idea but that’s kinda it.
As you said. RL experience can be quite different

The results on my M1 vary between 13 and inf…idk

The pinebook pro is running off emmc. I did not get the NVME adapter as it was reported to kill battery life and not offer much improvement. The Pi 5 was running off of a uSD card. Browsing on either of those or the a311d reform is more than acceptable just never felt quite as snappy as x86 performance that benchmarked worse.

Browsing on the pi5 is just about on par with x86 and you’re right nvme might be enough to make it feel that much better. I am excited for the rk3588 board.

1 Like

Just ran the test on my reforms using Firefox on Gentoo:

  • imx8mq: 0.881
  • ls1028a: 1.14

That feels about right to me. Browsing on the ls1028a feels better by about that much I’d say.

just for comparison i ran this benchmark under firefox on OpenBSD on imx8mq and this combination is Schrödinger’s browser - the tab crashed, rendering the performance unknowable. some secrets are best left buried i guess.

my limited experience testing out my openbsd installation has been pretty disappointing. firefox routinely dumps core, and the wifi iwn driver constantly yields device timeouts, requiring a reboot. firefox, when working, has been very, very slow. much worse than under alpine on the same hardware.

you likely need to tune your login.conf and possibly sysctls to allow firefox to have more memory and stack. one quick thing you can do is make sure your user is in the staff login class. firefox is pretty usable for me on OpenBSD (including on reform) but firefox also makes a deliberate decision to fail if a malloc() fails for any reason, and failing malloc() is pretty common on OpenBSD based on how the memory limits are imposed. i’d suggest reading up on datasize-* and stacksize-* login.conf settings as a start.

thanks. i do all this already in openbsd on every platform.