Repair support, MNT frozen with super hot motherboard

I left my reform (daily driver) plugged in the power outlet for lunch, I came back and

  • the system was shut down
  • system controller is not responding
  • the motherboard is super hot

I tried connecting/disconnecting the battery cells but the controller is still not responding. I checked the motherboard (seeking D5) and I found this

If you look carefully, R53 is now merged with R172 :face_holding_back_tears:

Today I used an AC adapter that outputs 19V, 6.3A as I forgot mine at the office. I checked the manual before doing so, 9-30V should be fine right? Another thing I did is a full apt update/upgrade

How should I proceed? Tomorrow I’ll move the resistor to its slot, is there anything else I should check before attempting a boot again?

Also notice the anomalous brownish paste over r27 and r28, did they release it?

The connection between R53 and R172 is intentional! See this update.

Regarding the brownish paste: my guess is that it’s flux. Should come off with a bit of rubbing alchohol.

2 Likes

This sounds similar to what happened to my laptop. I needed to send in the motherboard+SoC for repair.

Thanks for joining :wink: I’ve read the thread and the symptoms are indeed similar. I’ll give it a try removing D5! @mntmn WDYT?

update:

  • D5 continuity check OK, leaving it there for now
  • F2 is fused, I’m replacing it

Hey, sorry that you encountered this problem. How exactly did you test D5? In the diode failure case, continuity is there, i think in both directions. Do you have a diode tester in your multimeter?

Nice catch, continuity is OK meaning it is not OK then :joy: It is the only diode I tested which “bips” (in both directions)!

1 Like

I would suggest removing it then!

I have few experience in de-soldering, any suggestion before I dig a hole in the motherboard?

@mntmn is this assumption correct? (the 6A detail was missing)

Yep, that’s more than enough.

  1. I recommend that you get tacky flux (best is from Chipquik) and apply it to the component so that you don’t burn things up and get better solder flow.

  2. A technique I use with small components is to “pick them up” with a large blob of solder, which heats the whole component and both of its legs up at the same time, see: https://twitter.com/minut_e/status/1383458175685251073?s=20

  3. Here is a written guide: https://blog.sra-solder.com/knowledge-base/how-to-desolder-an-smd-with-a-soldering-iron

You can also try to find some videos on youtube. Preparation is key!

2 Likes

Wow thanks for the hint! I’ll let you know how it goes :smiley:

@mntmn So today (after 1 month) I finally received the fuses from lcsc so I replaced F2. I previously de-soldered D5 successfully thanks to your advices. The system booted fine (yeah) on battieries but as soon as I plugged the power jack in (with the stock reform charger this time) the system shut down and now:

  • when powered from batteries the system controller is responding but the system is no longer booting. No signals even from UART
  • when powered from wall power (batteries unplugged): no responses. LED D8 turns on
  • when both wall power and batteries are plugged the behavior is the same as the batteries were unplugged – no responses

How should I proceed?

It sounds like there is more damage to the motherboard related to the charger circuit. I would suggest not connecting the wall power at this point. How is the health of the batteries? Are they still at nominal voltages?

I would suggest to remove the i.MX module and the batteries, and first check the status of the motherboard/keyboard combo in isolation. The goal is to see if all the correct voltages are generated in the turned on state and the standby state (in standby, only the LPC_VCC 3.3V standby voltage should be there, and of course everything related to power input.)

Do you have a lab power supply? That way you can limit current and make sure it won’t create magic smoke if there is a short.

If and only if you have a controlled (current limited) power input, I would measure on the motherboard with a multimeter:

  • LPC_VCC (for example across C50): should be 3.3V in any state

Once turned on,

  • LEDs D12 and D11 should be on, indicating power on 3V and 5V rails
  • 3V3 rail voltage should be 3.3V (for example across C167, near display connector)
  • 1.8V should be 1.8V (across C112, southesat of C167)
  • 1.2V should be 1.2V (across C37, northeast of coin cell holder BT1)
  • 1.5V across C34 (east of C37)
  • 5V across C33 (south of C34)

If you don’t have a controlled power supply, you can check the above rails for shorts. Before doing that, disconnect everything from the motherboard. Then, use the multimeters beeper function across the capacitors mentioned above. If something beeps, that’s bad.

If you don’t find a problem/short, I would suggest you send us the board for repair. You can contact support@mntre.com to get that going.

1 Like

An update: while I’m waiting for a lab power supply I did the short checks: none of the above beeps!