ZZ9000 Video interference in Scan Doubled modes

  • Amiga model: A4000TX
  • 680x0 CPU: 68060 (A3660 @ 50 MHz)
  • RAM Configuration: 2 MB Chip, 16 MB MB Fast, 256 MB ZZ9000
  • Kickstart, AmigaOS Versions: 3.2
  • ZZ9000 Firmware version: 1.9 (same on 1.8)
  • ZZ9000 Driver version: 1.8
  • Monitor model: Eizo Flexscan S2100
  • Other Zorro cards: NIL

I noticed this after installing an A3660 card. Scan doubled modes exhibit video interference via the ZZ9000. Note RTG modes are fine, and using the 15KHz output from the A4000TX direct to a second monitor is also fine.

Based on this I’m thinking interference from the Video connector or ribbon cable???

When using the built-in 030 @ 25MHz I didn’t see this behaviour.

Take a look at this YT clip. The interference can be seen from 10 sec into the clip.

Just an update on this looks like a can consistently repro this now. The issue appears when USB is in use. So if mount a USB drive, I’m guessing when I run sysinfo it might initially scan all devices, causing the interference.

But when run the disk test it will consistently cause inteference on speed testing the USB drive. It’s hard to see in the video but much much more visible to the naked eye.

See video:

Now I know what is causing the issue I can live with it, but any suggestions to quiet down the USB port would be appreciated.

Any response from MNT?

This is going to sound a little strange but if you drop to 640x512x8 bit resolution do you still get the same effects?

Hi Steve,

I tried both 640x512x8 (RTG) and PAL Interlaced (Flicker fixed) and it seemed fine.

I’ll do some more testing update.

Your experience correlates well with mine. I had no end of trouble with my A3660 setup until I realised that not using USB and not running in 1920x1080x16 bit sped things up significantly. I don’t know if it’s a Buster issue, Z3 Ram access speeds, an A3660 issue or a ZZ9000 issue but it might be worth seeing what trade-off on resolution/colour depth is optimal for you.

I have since bought a Cyberstorm MkII and all of my problems disappeared immediately.

1 Like

Hi, sorry for the trouble, unfortunately I cannot reproduce the issue as I don’t have an A3660 (yet). It might be an issue with 5V rail voltage levels. USB requires additional power. If it is an HDMI interference issue you could try a different HDMI cable. Did you try other USB devices?

Might be worth looking at this thread. It might be worth checking the existing DTACK value in mon, then trying the pokew mentioned and checking different resolutions.

I have a slight suspicion that a timing issue between the A3660’s fast CPU without onboard memory could lead to bus timing issues when the ZZ9000 is busy (e.g. using Z3RAM/USB/Ethernet at higher resolutions), but this is all a little above my pay grade.