ZZ9000 Zorro 3 locking up

Hello

I have an A3000 with a ZZ9000 working fine. It’s an 030 model with 16MB Fast RAM.

I have another A3000 which locks up when drawing Workbench windows. I can accurately cause this to happen by running Intuispeed and it will lock up 100% of the time on any of the Workbench window tests (layers, resizing, moving). Outside of this benchmark, it seems to work fine but then will just lock up randomly when opening a drawer or starting an app after just a couple of minutes.

This A3000 has a A3660 but otherwise is the same.

I have tried rolling back to 1.8 firmware and drivers. I have tried the no fast firmware.

These 3000s are in Checkmate cases so they have a custom daughterboard. However it’s electrically the same, it just has 3 slots not 4. It works with other Zorro 2 and Zorro 3 cards such as Picasso 2, X-Surf 100. Also, the first 3000 works fine and I’ve swapped daughterboards with no improvement.

Are there any 060 compatibility issues? The only other difference between the machines is the working one has Ramsey 07, the unstable one Ramsey 04.

It seems focused on Intuition drawing, other graphics benchmarks like Linedrawing seem to work OK.

The Bus Test in ZZTop crashes instantly.

  • Amiga model: A3000
  • 680x0 CPU: 68RC060
  • RAM Configuration: 2MB Chip, 16MB Fast in ZIP
  • Kickstart, AmigaOS Versions: 3.2
  • ZZ9000 Firmware version: 1.9.1
  • ZZ9000 Driver version: 1.9
  • Monitor model: Dell 2410 (supports 50Hz)
  • Other Zorro cards: none

Hi,

thanks for the bug report. With custom Amiga builds there can be many issues and we often don’t have the hardware to reproduce these. What you can try is adjusting the DTACK timeout time with FW1.9.1.

To do this, first download Mon: Aminet - dev/moni/mon165.lha

Then, find the ZZ9000’s address using SYS:Tools/ShowConfig. Find the board with Prod=28014. For example, the address could be $4000000.

In a CLI, run mon from the package above. Then enter:

pokew 4001020 2

While replacing the first number with your ZZ9000’s address plus 0x1020 added. The second number is the DTACK timeout value. You can try values between 1 and 1f (hexadecimal) to see if that changes the behavior. The default value is 6.

2 Likes

Thanks, that’s something I can do and report back.
Should it be a case of tying a new value and seeing if it behaves any better? Will the change persist over a reboot?

Thanks!

Hi @mntmn - first impressions are it’s certainly a lot more stable, I went all in and set it to 1F because why not :smiley:

I’ll keep testing, but is there a way to automate this change so I don’t have to keep manually going into mon and typing that?

Happy to share details of the system to help you work out any issues, but it might be just a strange enough config that it’s “one of those things”. It’s an A3660 with RC060 @50MHz, Ramsey -04

1 Like

Just to confirm, this machine has now been 99% stable for the past few days - and I’ve been running it hard, installing things and flicking from program to program.

It still has that issue where the 256MB RAM doesn’t appear on first boot, but a warm boot shows up and I tried copying 180MB of games into RAM and running some, no issues so it looks like poking 40001020 fixes both graphics and memory. The 1% really can be put down to a 30 year old machine, a brand new OS and some random mixes of programs - all Amigas crash once in a while yeah?

I got a script sorted to do it on every boot, but is there scope for this to be worked into the firmware somehow?

2 Likes

This looks very similar to an issue I experienced when I had an A3660. Could you restore the original value and see if you have the same crashes at lower resolutions, or more so at higher resolutions? If the pokew solves that this could really help A3660 users.

Sadly it’s not my machine - my ZZ9000 lives in my 4000 with a Cyberstorm, it was a machine I was building for a friend.

I’m almost positive we tried every combination of resolution and colour depth, and whilst it seemed to happen more quickly at higher resolution none of them were stable and it would always lock up after just a few minutes maximum.

I recently found and fixed another bug in the ZZ9000 register write handling. Here’s a beta firmware, looking forward to your results:

http://dump.mntmn.com/zz9000-fwpack-110-20220429.zip

The included BOOT.bin-z3-20220429 needs to be renamed to BOOT.bin and placed on the MicroSD card that goes into ZZ9000.